summaryrefslogtreecommitdiff
path: root/dev-ruby/yard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 11:36:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 11:36:37 +0100
commitd6fe3a53bdeea6b060d1755199cc2c27492dc14c (patch)
tree7bb8240ab620eafcfe59b3d1b45831bf45e12501 /dev-ruby/yard
parent4bbcd26e7cb1908fb98bb318bfaa13ea9e32d860 (diff)
gentoo auto-resync : 10:04:2023 - 11:36:36
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/Manifest2
-rw-r--r--dev-ruby/yard/yard-0.9.32.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
index 35e45da0a4d3..c2569a09bc81 100644
--- a/dev-ruby/yard/Manifest
+++ b/dev-ruby/yard/Manifest
@@ -1,5 +1,7 @@
DIST yard-0.9.28-git.tgz 932436 BLAKE2B 7340f6815698ddb85aa16752266af75ecd3e1f1a5f328e147dd8ea01a750c48259e6f3413bb5d00777d4e983b340b36b21110e058cf6b326973c0a7c3d756836 SHA512 f57ce1f63ab1763729c85121cf1ac5927d4f7c53eed2fb58b1ea7d700db22481e767926845558d3db31bcef50d0181f0b6cf449e558a5548243256cdda0cd355
DIST yard-0.9.29-git.tgz 937893 BLAKE2B ccba7682aa071b6be570d0a47558107469ca2200fa2c83e93744e840e270c71d7b3fb31e9d51ddc72ede34daa741f2135e2950afd1927643e9129d0879e8f18e SHA512 fba71ae8d205595ce320143c962e9ce5ad496c158067412b20ddbfd7b5f30ed1eb3185a12997108847553ca65709bbbfb7c00e71cc6d46616e2e488bba22c2f0
+DIST yard-0.9.32-git.tgz 937946 BLAKE2B 757a4a4ab04fc88c4d0be06a33e56ffe04140e59655e91054f3222aba5a495c65692efa58289f7c6519ca78309c6cce53d9cdeb8ba5e3cd79b7da62b1056eebc SHA512 9cb8752cf079c185936b6d201f9118f40723ad3237aeac6eade163cfbfa8caa7725f8feec00f76c36fd4f92fa37c140a727b07ec852cdb4211cc854ff22adddb
EBUILD yard-0.9.28.ebuild 2594 BLAKE2B ddfc39712bbab8d6b1d2817ce17da545685221ca41d801f2fb4cfdc902acc60d5f1806738d90b7b07e4526ceac66d8b893f43aa007413a90f5537bd20544a6fa SHA512 8a35ef3afe06dbf6cbbfb71b3f216a7a661333f26e5fc74f054cd3b56e146cf45cf113f1c827ecf247359a03795be062865394c679aa59561238cdf62ce4df12
EBUILD yard-0.9.29.ebuild 2596 BLAKE2B cbd7083e20e993b2895fed3db1d7a1631f721d6fc0669105bb92c3c993c0ba23de5880ba0b114a719c2cb8c1efbdea8a690b810c7851e40d87d7ca4fc4fee79a SHA512 5197c5dd8b01fe3d88adf50751ead6165f2c00b806289cf61d1dad49e084be20d2ed0d3be47f1ccb066382dd8f4a7c377bb6274d9537bf8ef576fb22559a668e
+EBUILD yard-0.9.32.ebuild 2596 BLAKE2B cbd7083e20e993b2895fed3db1d7a1631f721d6fc0669105bb92c3c993c0ba23de5880ba0b114a719c2cb8c1efbdea8a690b810c7851e40d87d7ca4fc4fee79a SHA512 5197c5dd8b01fe3d88adf50751ead6165f2c00b806289cf61d1dad49e084be20d2ed0d3be47f1ccb066382dd8f4a7c377bb6274d9537bf8ef576fb22559a668e
MISC metadata.xml 338 BLAKE2B 17efe658faab09d5935ba472a803a1267f7606a44b157f29bcdecc8cea8af90902ae47012fdd4426357a8ceba5526ca24d737be8fe161c34e28e5362ccc94f16 SHA512 d1f45e2202c86b247b1b872ada72fef392d20260bc3ccc78164c26614dc80b8fe05518356248e3e7f15e2c70b29a9c0909bc738267261eb808965bcb0ed4ebc9
diff --git a/dev-ruby/yard/yard-0.9.32.ebuild b/dev-ruby/yard/yard-0.9.32.ebuild
new file mode 100644
index 000000000000..f84c056ecf99
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.32.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+RUBY_FAKEGEM_GEMSPEC="yard.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lacks the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( dev-ruby/rack:2.2 >=dev-ruby/rspec-3.11.0 )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '3igem "rack", "~> 2.2.0"' spec/spec_helper.rb || die
+
+ sed -i -e '/samus/I s:^:#:' Rakefile || die
+
+ sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+
+ # Avoid specs that only work with bundler
+ sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
+ sed -e '/overwrites options with data in/askip "wrong assumptions on file access"' \
+ -e '/loads any gem plugins starting with/askip "wrong assumptions on file access"' \
+ -i spec/config_spec.rb || die
+
+ # Avoid specs making assumptions about how rubygems works internally
+ sed -i -e '/searches for .gem file/askip "rubygems internals"' spec/cli/diff_spec.rb || die
+
+ # Fix broken spec
+ sed -i -e '/:exist?/aallow(File).to receive(:exist?).and_call_original' spec/i18n/locale_spec.rb || die
+
+ # Avoid ruby31 failure on whitespace-only differences
+ sed -i -e '/shows a list of nodes/askip "Whitespace differences on ruby31"' spec/parser/ruby/ast_node_spec.rb || die
+
+ # Avoid redcarpet-specific spec that is not optional
+ sed -i -e '/autolinks URLs/askip "make redcarpet optional"' spec/templates/helpers/html_helper_spec.rb || die
+
+ # Avoid asciidoc-specific spec that is not optional
+ sed -e '/\(AsciiDoc specific\|AsciiDoc header\)/askip "skipping asciidoc test"' \
+ -i spec/templates/helpers/html_helper_spec.rb || die
+}