summaryrefslogtreecommitdiff
path: root/dev-ruby/yard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/yard
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/Manifest5
-rw-r--r--dev-ruby/yard/metadata.xml11
-rw-r--r--dev-ruby/yard/yard-0.9.11.ebuild40
-rw-r--r--dev-ruby/yard/yard-0.9.14.ebuild43
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
new file mode 100644
index 000000000000..7e3200ab3340
--- /dev/null
+++ b/dev-ruby/yard/Manifest
@@ -0,0 +1,5 @@
+DIST yard-0.9.11-git.tgz 916355 BLAKE2B e9f27fe129cf93c51dbf83f4a7d5745d385252ba63c90f85223f2e9436c22a55aaba296f263072069d39e4beaca3e0830775a8be121c64cdc2a15afd3539a73f SHA512 375a4878e61888cf73aaa06e9300195ae48b9898d8cd639fa796a067e5fa0b89d6ef62d327a388ee83953e80177515f4d8c070042188e3a1e597f48b82b3a72e
+DIST yard-0.9.14-git.tgz 917830 BLAKE2B dd0d1d6dbc5aa9b549bd4c110f1abd57edc76b85e7c936bca8f7d35761d705ba86cd169c3c2b2141095dda68a8ab350b46bcbeb978d655addff78b110fbd2b71 SHA512 7974d431b2c1ef4830f225fd2012592405e7fb63546aeb52b74f4ad8b498926be979f3010bd315877bb4f738f6aa6c31f54b71832b461ebd3fa54fe1a1fccf5f
+EBUILD yard-0.9.11.ebuild 1317 BLAKE2B 491c69e138eae9ce9b3e8c80b266910414bea131d6dffc6788534f2519b674125fe316f1d7c5c4a56bfb9e6bb10042eeea3a08e6243a3fd5d2992900b0e7a6ba SHA512 7461bdb4de4b211037e2f616e5614c995a8f62f691777348c8f549b58d22b395df6b29e0d625bc3e308a7bdd2cb707bb09dcc4d3fc451fabbed04f1635328b30
+EBUILD yard-0.9.14.ebuild 1440 BLAKE2B 1130caaab8d43bf4cad4c7669d6b5a6b93b5703ef1020d18eb52d32fac14a4e330c69d05746462df7f9a8a3fce4d74ae6b14a03dcd9bd63d77ef764cae353fb4 SHA512 be5266e5244726469c82fb2a133f4b54fb1080886b051de5edebdbb0d3856bb157c6e442e9c24a796b27bbd601e386559c8f1334be0b83bfc4bc628936dcca11
+MISC metadata.xml 337 BLAKE2B 1aedede1271d1f9a566743dd25b1fd9961e429b78bb5f9f36bd6ea66f631f376a273d7a094fba7121d099f3a4a3f0e7738753078e2a1a554cfe6cf32acc6e2b6 SHA512 0de30cc9c4a9d08649f141cb6df0ee9c05703831603c77a0605f0bf8e2f49b8324a782d092aaa690581e23d6d948fda9781b98770a3ba89ed6bfc0de351c11bb
diff --git a/dev-ruby/yard/metadata.xml b/dev-ruby/yard/metadata.xml
new file mode 100644
index 000000000000..55feb7157006
--- /dev/null
+++ b/dev-ruby/yard/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lsegal/yard</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/yard/yard-0.9.11.ebuild b/dev-ruby/yard/yard-0.9.11.ebuild
new file mode 100644
index 000000000000..b70b4dd17ad5
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lakes the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/bluecloth dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( >=dev-ruby/ruby-gettext-2.3.8 dev-ruby/rack dev-ruby/redcloth )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+}
diff --git a/dev-ruby/yard/yard-0.9.14.ebuild b/dev-ruby/yard/yard-0.9.14.ebuild
new file mode 100644
index 000000000000..878b62659879
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.14.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lakes the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/bluecloth dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( >=dev-ruby/ruby-gettext-2.3.8 dev-ruby/rack dev-ruby/redcloth )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+
+ # Avoid specs that only work with bundler
+ sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
+}