summaryrefslogtreecommitdiff
path: root/dev-ruby/yard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-ruby/yard
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/Manifest2
-rw-r--r--dev-ruby/yard/yard-0.9.26.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
index d750e191b559..f9449b120bc7 100644
--- a/dev-ruby/yard/Manifest
+++ b/dev-ruby/yard/Manifest
@@ -1,5 +1,7 @@
DIST yard-0.9.20-git.tgz 921130 BLAKE2B 37b1b2524147a1a8cb36c3835cce4e7666e2c8d3d5c187eb402000fb251df64111c4f104957ac9d28bd0e8d9328eb1d97571337ae54479626dcaab3cf07625a6 SHA512 b7e035a3598c8ef32fcbaae57254c0fb0cba875606b434571da2ef754f3171b5c42a4b3a45bd4bf41bce368f6fb7e448567f601a9cab5fbdae695bbec1b73608
DIST yard-0.9.25-git.tgz 930253 BLAKE2B 35531a7e90ab99bad8d236ea4774a8aebc50eff5d78f60e2dfea8edb2af965dc60e8c02f8a1f95166e80d6f1ce21aca051b92b2511b88a7d87d2cc90e58bcd17 SHA512 855bf05ce45a965d534191b036831ec1cedc848e21196ed93cc7984d744328d9d5ba39664b4539a707a1556984990360cd27e085b830501ac8d72c6cebb3e689
+DIST yard-0.9.26-git.tgz 930901 BLAKE2B 19baaefc54269bbc7eee053b42f2be85644a062cbf55b0fafb63748876aad3a3143767855f4ee7b10a1ae814110a6cf63c01e4055e054aeb31bf8512e793d80d SHA512 0f70a089d5e5ba33e326b0ae0cc84a2cacfc5a3f3080545d5fc5bb324dedbbbf65116cc9412b3496c09b2b6c15514e854a741a1fd7e2ae782804d6e4ac28fcd9
EBUILD yard-0.9.20.ebuild 1777 BLAKE2B 95781d05b6b42f22027c5494cd6ad909a2f580e8ad13b4cccc5b42e20eb2e278f00c0c65e727cdfef73f2459c6b9c086f390f3c360a4bcad149b920b7c88a051 SHA512 db14445f362c68eabf02c00b9370febb38e9d30ba6167832e4a36bb8422c81622871af6878c86c52263fd30436f9041bd02d0ebe56c59542be47ed901479ff33
EBUILD yard-0.9.25.ebuild 2069 BLAKE2B d3561aa9c61c9be966f138fc40ed408c1f503a26f6c8adc82788beaf3084f7489b7618c108088d7b5941dc09e6d32749712c321634273f2717597bef07c9dd5f SHA512 fa6d2f1012983738c1886cecab4390d8900584549b46b92967e0d9b68c90a5df0abca10856b3a4b9991ba955a1bcf3496fb544b85fc2a5a9fe50d160f7afd0e4
+EBUILD yard-0.9.26.ebuild 2062 BLAKE2B b36c92edc910299ae765d955c1ee9d2ffde4ac0f9a404d6126f9b8fefbc62f0d45c2dd72bc78d05dfc32947447e3480e7dabb1b245175f0e3183918bc648c29e SHA512 2200a0d5290ff258b9ea814e6e52bf29b56add1aaee72a2f7a45033289d2956ef08c66c4368ee3798c90ee459cb45647730a96fe98eb85ef02dd6f399744d562
MISC metadata.xml 337 BLAKE2B 1aedede1271d1f9a566743dd25b1fd9961e429b78bb5f9f36bd6ea66f631f376a273d7a094fba7121d099f3a4a3f0e7738753078e2a1a554cfe6cf32acc6e2b6 SHA512 0de30cc9c4a9d08649f141cb6df0ee9c05703831603c77a0605f0bf8e2f49b8324a782d092aaa690581e23d6d948fda9781b98770a3ba89ed6bfc0de351c11bb
diff --git a/dev-ruby/yard/yard-0.9.26.ebuild b/dev-ruby/yard/yard-0.9.26.ebuild
new file mode 100644
index 000000000000..2650101cbad8
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.26.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+RUBY_FAKEGEM_GEMSPEC="yard.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lakes the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( dev-ruby/rack )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e '/samus/I s:^:#:' Rakefile || die
+
+ sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+
+ # Avoid specs that only work with bundler
+ sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
+ sed -e '/overwrites options with data in/askip "wrong assumptions on file access"' \
+ -e '/loads any gem plugins starting with/askip "wrong assumptions on file access"' \
+ -i spec/config_spec.rb || die
+
+ # Avoid redcarpet-specific spec that is not optional
+ sed -i -e '/autolinks URLs/askip "make redcarpet optional"' spec/templates/helpers/html_helper_spec.rb || die
+
+ # Avoid asciidoc-specific spec that is not optional
+ sed -i -e '/\(AsciiDoc specific\|AsciiDoc header\)/askip "skipping asciidoc test"' spec/templates/helpers/html_helper_spec.rb || die
+}