summaryrefslogtreecommitdiff
path: root/dev-ruby/yard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-ruby/yard
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/Manifest2
-rw-r--r--dev-ruby/yard/yard-0.9.28.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
index 82215ccea7e5..f40f954d9ee9 100644
--- a/dev-ruby/yard/Manifest
+++ b/dev-ruby/yard/Manifest
@@ -1,5 +1,7 @@
DIST yard-0.9.26-git.tgz 930901 BLAKE2B 19baaefc54269bbc7eee053b42f2be85644a062cbf55b0fafb63748876aad3a3143767855f4ee7b10a1ae814110a6cf63c01e4055e054aeb31bf8512e793d80d SHA512 0f70a089d5e5ba33e326b0ae0cc84a2cacfc5a3f3080545d5fc5bb324dedbbbf65116cc9412b3496c09b2b6c15514e854a741a1fd7e2ae782804d6e4ac28fcd9
DIST yard-0.9.27-git.tgz 932022 BLAKE2B 7390e81081c6785cd7174b9ece57dafc27a9762f0751f05bfc222d561c6b6f5a5ff1a757fc24020a6adb2014c3e77696b6e8c054f7f6918120f6db435739b977 SHA512 20f406234bed52eff254c1b1dd0e3dcbc08109e9a285e4e4041c164cd998ae00654d2414e0e442e3a9520afc5cae2c1bd5010dd25fa38ef16ee21f077527aae4
+DIST yard-0.9.28-git.tgz 932436 BLAKE2B 7340f6815698ddb85aa16752266af75ecd3e1f1a5f328e147dd8ea01a750c48259e6f3413bb5d00777d4e983b340b36b21110e058cf6b326973c0a7c3d756836 SHA512 f57ce1f63ab1763729c85121cf1ac5927d4f7c53eed2fb58b1ea7d700db22481e767926845558d3db31bcef50d0181f0b6cf449e558a5548243256cdda0cd355
EBUILD yard-0.9.26.ebuild 2058 BLAKE2B 4950a872e570df40aadad0bf13a59ab99bfe09684dbc8eb5146f0dad2ce9bd7512cdd576abc1e3b7cfd9db512c08b9ed0629bffd828d40c7cb91bfdf561b54a3 SHA512 efba53869ead017865a1f44e904343c3b5878d8e53d1323a1e9bd6e348d4235557ab8fbeaad40ed9b715d76e239dbdd70a394275880e139e2b2e4b48c6e328cd
EBUILD yard-0.9.27.ebuild 2107 BLAKE2B 310fadf5ef71df24d357e26413cc57de82edabd99da37f74c0eccb26ad4d41bf182ea726ece7313d11d396a6a6c5c3ac533bf5ebb2d69d8b3eaf9951be3504bb SHA512 afe104124991871f3e0be67d8acf79abb9af269ff1f52d6a5f81b0a1b1ec74a563b81f4321af255118584d4b49acc93ed92ea362262f30bad9609cfc31db3228
+EBUILD yard-0.9.28.ebuild 2601 BLAKE2B a2f2e670f3a543a0e740ca433400e9aea8dde6fc61b2a37b8149f94ad2e26618f22adff0d349fda84bc14abce5c7bb39e79f2c2679fe044f70c148887e888970 SHA512 be3c5ed1ca9d91fb07ccf5eebd10bec2141fcd00033dc166ed56a1980d0b22a5d5ba6b3f7d479eb93b761e3cae1ee1b44aacb074193c80f4d59766099db44688
MISC metadata.xml 338 BLAKE2B 17efe658faab09d5935ba472a803a1267f7606a44b157f29bcdecc8cea8af90902ae47012fdd4426357a8ceba5526ca24d737be8fe161c34e28e5362ccc94f16 SHA512 d1f45e2202c86b247b1b872ada72fef392d20260bc3ccc78164c26614dc80b8fe05518356248e3e7f15e2c70b29a9c0909bc738267261eb808965bcb0ed4ebc9
diff --git a/dev-ruby/yard/yard-0.9.28.ebuild b/dev-ruby/yard/yard-0.9.28.ebuild
new file mode 100644
index 000000000000..5953b2cb14ba
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.28.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+RUBY_FAKEGEM_GEMSPEC="yard.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lakes the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/webrick-1.7*"
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( dev-ruby/rack >=dev-ruby/rspec-3.11.0 )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e '/samus/I s:^:#:' Rakefile || die
+
+ sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+
+ # Avoid specs that only work with bundler
+ sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
+ sed -e '/overwrites options with data in/askip "wrong assumptions on file access"' \
+ -e '/loads any gem plugins starting with/askip "wrong assumptions on file access"' \
+ -i spec/config_spec.rb || die
+
+ # Avoid specs making assumptions about how rubygems works internally
+ sed -i -e '/searches for .gem file/askip "rubygems internals"' spec/cli/diff_spec.rb || die
+
+ # Fix broken spec
+ sed -i -e '/:exist?/aallow(File).to receive(:exist?).and_call_original' spec/i18n/locale_spec.rb || die
+
+ # Avoid ruby31 failure on whitespace-only differences
+ sed -i -e '/shows a list of nodes/askip "Whitespace differences on ruby31"' spec/parser/ruby/ast_node_spec.rb || die
+
+ # Avoid redcarpet-specific spec that is not optional
+ sed -i -e '/autolinks URLs/askip "make redcarpet optional"' spec/templates/helpers/html_helper_spec.rb || die
+
+ # Avoid asciidoc-specific spec that is not optional
+ sed -i -e '/\(AsciiDoc specific\|AsciiDoc header\)/askip "skipping asciidoc test"' spec/templates/helpers/html_helper_spec.rb || die
+}