summaryrefslogtreecommitdiff
path: root/dev-ruby/wisper/wisper-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-ruby/wisper/wisper-2.0.1.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-ruby/wisper/wisper-2.0.1.ebuild')
-rw-r--r--dev-ruby/wisper/wisper-2.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/wisper/wisper-2.0.1.ebuild b/dev-ruby/wisper/wisper-2.0.1.ebuild
new file mode 100644
index 000000000000..5231ea77d3e4
--- /dev/null
+++ b/dev-ruby/wisper/wisper-2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A micro library providing objects with Publish-Subscribe capabilities"
+HOMEPAGE="https://github.com/krisleech/wisper"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/coverall/I s:^:#:' spec/spec_helper.rb || die
+}