summaryrefslogtreecommitdiff
path: root/dev-ruby/wirble/wirble-0.1.3-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-ruby/wirble/wirble-0.1.3-r5.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-ruby/wirble/wirble-0.1.3-r5.ebuild')
-rw-r--r--dev-ruby/wirble/wirble-0.1.3-r5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/wirble/wirble-0.1.3-r5.ebuild b/dev-ruby/wirble/wirble-0.1.3-r5.ebuild
new file mode 100644
index 000000000000..43536f9ebca6
--- /dev/null
+++ b/dev-ruby/wirble/wirble-0.1.3-r5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wirble is a set of enhancements for Irb"
+HOMEPAGE="http://pablotron.org/software/wirble/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+pkg_postinst() {
+ elog "The quick way to use wirble is to make your ~/.irbrc look like this:"
+ elog " # load libraries"
+ elog " require 'rubygems'"
+ elog " require 'wirble'"
+ elog " "
+ elog " # start wirble (with color)"
+ elog " Wirble.init"
+ elog " Wirble.colorize"
+}