summaryrefslogtreecommitdiff
path: root/dev-ruby/will_paginate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/will_paginate
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/will_paginate')
-rw-r--r--dev-ruby/will_paginate/Manifest3
-rw-r--r--dev-ruby/will_paginate/metadata.xml11
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.1.6.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/will_paginate/Manifest b/dev-ruby/will_paginate/Manifest
new file mode 100644
index 000000000000..8fe0cb5976a0
--- /dev/null
+++ b/dev-ruby/will_paginate/Manifest
@@ -0,0 +1,3 @@
+DIST will_paginate-3.1.6.gem 36864 BLAKE2B c6babf7125c20d7ed646930b7df39db864d0d46fd89d743daab73ba35254650ec0b4c7e203c5d5a2b00439d928b95508c1a82107db142f8cd77d27a14be00e7f SHA512 50e0fed5a3ea6a62f8620db3d30046a7a4cc602d9d7936a265d0c20a50eb267ecebb2c7d3bb07f3a514f70e556dad78085971bb80f94e1f4baf7048d6fd34c11
+EBUILD will_paginate-3.1.6.ebuild 681 BLAKE2B 3d5417cab8dc2379621df378a0e767ef5a0e9e2f5aef78ac17496d8cf7c313c4693072c66ff36745576acdef5b21ad504a714959da090383c4711ab80599369a SHA512 606e40042db68a5b7d22d96e85d38caf8684b56f4a3cfd3b9a3d04f7568d946b826bd80bddfa10e048e5b49bd9b1f996ed891f93b3687db8f6c4cb2d075ff8ad
+MISC metadata.xml 346 BLAKE2B 859514393fc9d9ac988a812dbb5fc126a269616351c6d8fc32c6ec0f25d685c835f4c1d27ce818807bb330fdc50839b81e6f63d0eb4d77d8f6a95f2da3d849af SHA512 2e061bf277b39327fb84988df2dd9cf548c87dc0bdc51e63b47aeb816c099a4a7fa5b95fc1f3ba35e15c7499d897770397c6f6f2f4d3c1b03733f16f1d0556d3
diff --git a/dev-ruby/will_paginate/metadata.xml b/dev-ruby/will_paginate/metadata.xml
new file mode 100644
index 000000000000..c9ac7a14579c
--- /dev/null
+++ b/dev-ruby/will_paginate/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mislav/will_paginate</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/will_paginate/will_paginate-3.1.6.ebuild b/dev-ruby/will_paginate/will_paginate-3.1.6.ebuild
new file mode 100644
index 000000000000..e9964593ec26
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-3.1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby"
+HOMEPAGE="https://github.com/mislav/will_paginate/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~x86-macos"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '1igem "rails", "<5"' spec/spec_helper.rb || die
+
+ # Remove tests for unpackaged ORMs
+ rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+}
+
+ruby_add_bdepend "
+ test? (
+ <dev-ruby/rails-5
+ dev-ruby/mocha
+ )"