summaryrefslogtreecommitdiff
path: root/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
commit616579b5d773c50af31ee56f00105d96ce641ca2 (patch)
tree2ad4d3ba1429bd93a36ab99a2f5ec3490412115e /dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
parent068424b26532f3551a81421a9be67ed206e5c11a (diff)
gentoo resync : 14.08.2021
Diffstat (limited to 'dev-ruby/will_paginate/will_paginate-3.3.1.ebuild')
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild b/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
new file mode 100644
index 000000000000..ce6a5ea33efd
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby"
+HOMEPAGE="https://github.com/mislav/will_paginate/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove tests for unpackaged ORMs
+ rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+}
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rails
+ dev-ruby/sqlite3
+ dev-ruby/mocha
+ )"