summaryrefslogtreecommitdiff
path: root/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-ruby/will_paginate/will_paginate-3.3.1.ebuild')
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.3.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild b/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
index ce6a5ea33efd..0c766344ec96 100644
--- a/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
+++ b/dev-ruby/will_paginate/will_paginate-3.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,11 +21,14 @@ IUSE=""
all_ruby_prepare() {
# Remove tests for unpackaged ORMs
rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+
+ # Use a supported rails version
+ sed -e '1igem "activerecord", "<7"; gem "actionpack", "<7"' -i spec/spec_helper.rb || die
}
ruby_add_bdepend "
test? (
- dev-ruby/rails
+ <dev-ruby/rails-7
dev-ruby/sqlite3
dev-ruby/mocha
)"