summaryrefslogtreecommitdiff
path: root/dev-ruby/will_paginate/will_paginate-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-ruby/will_paginate/will_paginate-3.3.0.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-ruby/will_paginate/will_paginate-3.3.0.ebuild')
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.3.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/will_paginate/will_paginate-3.3.0.ebuild b/dev-ruby/will_paginate/will_paginate-3.3.0.ebuild
new file mode 100644
index 000000000000..3f25988e7abf
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-3.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby"
+HOMEPAGE="https://github.com/mislav/will_paginate/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~x86-macos"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove tests for unpackaged ORMs
+ rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+}
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rails
+ dev-ruby/mocha
+ )"