summaryrefslogtreecommitdiff
path: root/dev-ruby/will_paginate/will_paginate-3.1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-ruby/will_paginate/will_paginate-3.1.8.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-ruby/will_paginate/will_paginate-3.1.8.ebuild')
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.1.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/will_paginate/will_paginate-3.1.8.ebuild b/dev-ruby/will_paginate/will_paginate-3.1.8.ebuild
new file mode 100644
index 000000000000..3c47cb11bdea
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-3.1.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby"
+HOMEPAGE="https://github.com/mislav/will_paginate/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~x86-macos"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove tests for unpackaged ORMs
+ rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+}
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rails
+ dev-ruby/mocha
+ )"