summaryrefslogtreecommitdiff
path: root/dev-ruby/webrobots
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/webrobots
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/webrobots')
-rw-r--r--dev-ruby/webrobots/Manifest4
-rw-r--r--dev-ruby/webrobots/metadata.xml12
-rw-r--r--dev-ruby/webrobots/webrobots-0.1.2-r1.ebuild34
-rw-r--r--dev-ruby/webrobots/webrobots-0.1.2.ebuild34
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-ruby/webrobots/Manifest b/dev-ruby/webrobots/Manifest
new file mode 100644
index 000000000000..2329db45e629
--- /dev/null
+++ b/dev-ruby/webrobots/Manifest
@@ -0,0 +1,4 @@
+DIST webrobots-0.1.2.gem 24064 BLAKE2B e77c7b83b16faa7c6d65f6133a5e2231a4e270d8463251c2e6a91a5bd1f11af431d4bca4f11bf40e2e84829c1b8256a39d048a371ce4a062af6bba9dafe25c49 SHA512 8b2a27a1758e613bced16b59a2b1708f468921388882d7ea483c7b6cbb5173fa24032f4db271734820225c5e90d3f30d07c5fb682d0d807c637f535ef7256097
+EBUILD webrobots-0.1.2-r1.ebuild 955 BLAKE2B 5051e81919edf5c18fdcf5c548762c4965769cc6c7127a84521b81847a542dcf8633b2483a206daa4ec61bbdee9f5a2589fd7afba656178f0d2be501d5e07b1b SHA512 da7857ed0e66764c26dd07c87f676d382947bf362ce3f4b454ad09a2ce3f89ae4cd03137b67c2788f969625adc475ff89936401ad67ce06b67e1031c42722f21
+EBUILD webrobots-0.1.2.ebuild 941 BLAKE2B 0b2edbeb1f2db94603d5723cde9fe3ec09e48dd8e1a99360fb95edc77496d286895bd381af77a000e8b732f91eceb18a4e0e4a9ed98c240f114b6d7946c8e911 SHA512 4a2ae2b257407f23c408664aae3232d6c0dc4d819ba95c084ea94a7ea76dea18338af128c383f4ad06356b027940d619fffdcc062ca05628071acd9ca29a6878
+MISC metadata.xml 380 BLAKE2B 9be818846cc0906eb21d32c72ed1c129d65e10133d8303535c65b942ec24dfba85f422186b754d42dedc9a0a0cb5bd7c28b9099f17543b007f012aec123fbb90 SHA512 0c68a9a014ac9459f1ed9639517189109e50cd101e8bc7c21ed2a3631e22ee7a7fc31c7f4518463170a63d710cb4b1e03a1bffa1275ca8e6629afe89cfa31b44
diff --git a/dev-ruby/webrobots/metadata.xml b/dev-ruby/webrobots/metadata.xml
new file mode 100644
index 000000000000..dc2b266475d2
--- /dev/null
+++ b/dev-ruby/webrobots/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="rubygems">webrobots</remote-id>
+ <remote-id type="github">knu/webrobots</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/webrobots/webrobots-0.1.2-r1.ebuild b/dev-ruby/webrobots/webrobots-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..413984e979ad
--- /dev/null
+++ b/dev-ruby/webrobots/webrobots-0.1.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to help write robots.txt compliant web robots"
+HOMEPAGE="https://github.com/knu/webrobots"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4"
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda dev-ruby/test-unit:2 dev-ruby/webmock dev-ruby/vcr )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/d' Rakefile test/helper.rb || die
+
+ # Avoid tests for live websites requirering a network connection.
+ sed -i -e '/robots.txt in the real world/,/^ end/ s:^:#:' test/test_webrobots.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}
diff --git a/dev-ruby/webrobots/webrobots-0.1.2.ebuild b/dev-ruby/webrobots/webrobots-0.1.2.ebuild
new file mode 100644
index 000000000000..d03f6eac6e84
--- /dev/null
+++ b/dev-ruby/webrobots/webrobots-0.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to help write robots.txt compliant web robots"
+HOMEPAGE="https://github.com/knu/webrobots"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4"
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda dev-ruby/test-unit:2 dev-ruby/webmock )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/d' Rakefile test/helper.rb || die
+
+ # Avoid tests for live websites requirering a network connection.
+ sed -i -e '/robots.txt in the real world/,/^ end/ s:^:#:' test/test_webrobots.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}