summaryrefslogtreecommitdiff
path: root/dev-ruby/virtus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ruby/virtus
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/virtus')
-rw-r--r--dev-ruby/virtus/Manifest4
-rw-r--r--dev-ruby/virtus/files/virtus-1.0.5-equalizer.patch208
-rw-r--r--dev-ruby/virtus/metadata.xml12
-rw-r--r--dev-ruby/virtus/virtus-1.0.5.ebuild36
4 files changed, 0 insertions, 260 deletions
diff --git a/dev-ruby/virtus/Manifest b/dev-ruby/virtus/Manifest
deleted file mode 100644
index 2837ebec9ade..000000000000
--- a/dev-ruby/virtus/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX virtus-1.0.5-equalizer.patch 8422 BLAKE2B 939c71ea56a77c1a654e7baf11e0f2ee40b044ad0dde0c1689a0e8c50789b6adf2f8586467f662c3d20e2a9643cda21ff9af865ee19c40ccc3e48069d43e1932 SHA512 70db78b928e1dc23df126bdd081db2664dcf75379e92d3480ad0dad951df9a91d0feaa40de570a6116a71708342d891c073b07395180d85cad50e9e3dd509020
-DIST virtus-1.0.5.gem 49152 BLAKE2B 24f422d96b10c38f9599c48a2018dac5b5bb8979acce1ee206b11d64d74a852ffbd276b78bd55b3b184cc109eb00d27ff1347d143695a4e06edfb94a3e87fd5b SHA512 468b74d6a49410bb4e59c535b9f7736cd5e4743817f19f97483247b0d259e17b069044bd5ccc787d72df972d37903eb7c9a9d6ca0c6642c550f1c84a3bc71825
-EBUILD virtus-1.0.5.ebuild 847 BLAKE2B 2f77089213e99544974a8742b2d19e96342a02b948a5beb3e796eb7558b9e7b5822d44274bf6cd44fc9228f061c1d9a7abbeff4762e8f5ef4986d1479ad5b1e7 SHA512 a0c00a9c32d9acfd803a55c5ab27a10df6185c8617b1daee90e5b63fdae1b4c50ed977c75e6a1728abc3d0202aa871d304bde8e28ddc00db27491f0356d86b4f
-MISC metadata.xml 389 BLAKE2B 19ea2d5c5c25b7fd2c9d4cc23141907def94233ae9d6e82cfa45817950fff4e8a927b361c46d1d370c6a418831f2ca8423d51fa29fd20d2929bb0efea283e996 SHA512 b8ce763b943ae56ae0ad2f49f87608d010a39f2a1bd8800572ca799d9ca28e419de8545bc5b3e813e10d0a352fb0e2253d2dd4d0ee601ecea0ec3a98e524c0e4
diff --git a/dev-ruby/virtus/files/virtus-1.0.5-equalizer.patch b/dev-ruby/virtus/files/virtus-1.0.5-equalizer.patch
deleted file mode 100644
index 22fc19298505..000000000000
--- a/dev-ruby/virtus/files/virtus-1.0.5-equalizer.patch
+++ /dev/null
@@ -1,208 +0,0 @@
-From 5f33f8147fc9d84e69a33758b000486ebe42c8ae Mon Sep 17 00:00:00 2001
-From: Sergey Novik <konnigun@gmail.com>
-Date: Sun, 19 Jul 2015 18:11:07 +0300
-Subject: [PATCH 1/3] Add specs for attributes comparison (based on latest
- Equalizer gem working version)
-
----
- spec/unit/virtus/attribute/comparison_spec.rb | 23 +++++++++++++++++++++++
- 1 file changed, 23 insertions(+)
- create mode 100644 spec/unit/virtus/attribute/comparison_spec.rb
-
-diff --git a/spec/unit/virtus/attribute/comparison_spec.rb b/spec/unit/virtus/attribute/comparison_spec.rb
-new file mode 100644
-index 0000000..0b51a9c
---- /dev/null
-+++ b/spec/unit/virtus/attribute/comparison_spec.rb
-@@ -0,0 +1,23 @@
-+require 'spec_helper'
-+
-+describe Virtus::Attribute, '#== (defined by including Virtus::Equalizer)' do
-+ let(:attribute) { described_class.build(String, :name => :name) }
-+
-+ # Currently that's the way it works and it happens because default_value objects
-+ # don't have equalizer, resulting in attributes object mismatch.
-+ # This behavior (and a spec) will need a change in future.
-+ it 'returns false when attributes have same type and options' do
-+ equal_attribute = described_class.build(String, :name => :name)
-+ expect(attribute == equal_attribute).to be_falsey
-+ end
-+
-+ it 'returns false when attributes have different type' do
-+ different_attribute = described_class.build(Integer, :name => :name)
-+ expect(attribute == different_attribute).to be_falsey
-+ end
-+
-+ it 'returns false when attributes have different options' do
-+ different_attribute = described_class.build(Integer, :name => :name_two)
-+ expect(attribute == different_attribute).to be_falsey
-+ end
-+end
-
-From 3748f6eb2cf368d6a78fb1ef50c2724648d96a9b Mon Sep 17 00:00:00 2001
-From: Sergey Novik <konnigun@gmail.com>
-Date: Sun, 19 Jul 2015 18:11:24 +0300
-Subject: [PATCH 2/3] Use Virtus::Equalizer instead of Equalizer gem in
- Virtus#Attribute (behavior preserved)
-
----
- lib/virtus/attribute.rb | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/virtus/attribute.rb b/lib/virtus/attribute.rb
-index 999a2ef..0654d4d 100644
---- a/lib/virtus/attribute.rb
-+++ b/lib/virtus/attribute.rb
-@@ -18,7 +18,7 @@ module Virtus
- class Attribute
- extend DescendantsTracker, Options, TypeLookup
-
-- include ::Equalizer.new(:type, :options)
-+ include Equalizer.new(inspect) << :type << :options
-
- accept_options :primitive, :accessor, :default, :lazy, :strict, :required, :finalize, :nullify_blank
-
-
-From ef57af319334a1d4f3e0860acbde7c6d6f0eb8ef Mon Sep 17 00:00:00 2001
-From: Sergey Novik <konnigun@gmail.com>
-Date: Sun, 19 Jul 2015 18:26:50 +0300
-Subject: [PATCH 3/3] Change behavior of Attribute#== method
-
-By changing Coercer#== and DefaultValue#== methods, we allow
-Attribute#== to actually compare objects now (before, every comparison
-would return `false` because of different instances of DefaultValue
-model in options[:default_value] key.
----
- lib/virtus/attribute/default_value.rb | 2 ++
- lib/virtus/coercer.rb | 1 +
- spec/unit/virtus/attribute/comparison_spec.rb | 7 ++-----
- spec/unit/virtus/attribute_set/append_spec.rb | 8 ++++----
- spec/unit/virtus/attribute_set/element_set_spec.rb | 22 +++++++++++++++-------
- spec/unit/virtus/attribute_set/merge_spec.rb | 8 +++++---
- 6 files changed, 29 insertions(+), 19 deletions(-)
-
-diff --git a/lib/virtus/attribute/default_value.rb b/lib/virtus/attribute/default_value.rb
-index a2fcd31..eca7350 100644
---- a/lib/virtus/attribute/default_value.rb
-+++ b/lib/virtus/attribute/default_value.rb
-@@ -7,6 +7,8 @@ class Attribute
- class DefaultValue
- extend DescendantsTracker
-
-+ include Equalizer.new(inspect) << :value
-+
- # Builds a default value instance
- #
- # @return [Virtus::Attribute::DefaultValue]
-diff --git a/lib/virtus/coercer.rb b/lib/virtus/coercer.rb
-index a06e273..676d553 100644
---- a/lib/virtus/coercer.rb
-+++ b/lib/virtus/coercer.rb
-@@ -3,6 +3,7 @@ module Virtus
- # Abstract coercer class
- #
- class Coercer
-+ include Equalizer.new(inspect) << :primitive << :type
-
- # @api private
- attr_reader :primitive, :type
-diff --git a/spec/unit/virtus/attribute/comparison_spec.rb b/spec/unit/virtus/attribute/comparison_spec.rb
-index 0b51a9c..796cd20 100644
---- a/spec/unit/virtus/attribute/comparison_spec.rb
-+++ b/spec/unit/virtus/attribute/comparison_spec.rb
-@@ -3,12 +3,9 @@
- describe Virtus::Attribute, '#== (defined by including Virtus::Equalizer)' do
- let(:attribute) { described_class.build(String, :name => :name) }
-
-- # Currently that's the way it works and it happens because default_value objects
-- # don't have equalizer, resulting in attributes object mismatch.
-- # This behavior (and a spec) will need a change in future.
-- it 'returns false when attributes have same type and options' do
-+ it 'returns true when attributes have same type and options' do
- equal_attribute = described_class.build(String, :name => :name)
-- expect(attribute == equal_attribute).to be_falsey
-+ expect(attribute == equal_attribute).to be_truthy
- end
-
- it 'returns false when attributes have different type' do
-diff --git a/spec/unit/virtus/attribute_set/append_spec.rb b/spec/unit/virtus/attribute_set/append_spec.rb
-index 7fbb20a..577b07e 100644
---- a/spec/unit/virtus/attribute_set/append_spec.rb
-+++ b/spec/unit/virtus/attribute_set/append_spec.rb
-@@ -38,10 +38,10 @@
-
- it { is_expected.to equal(object) }
-
-- it 'replaces the original attribute' do
-- expect { subject }.to change { object.to_a }.
-- from(attributes).
-- to([ attribute ])
-+ it "replaces the original attribute object" do
-+ expect { subject }.to change { object.to_a.map(&:__id__) }.
-+ from(attributes.map(&:__id__)).
-+ to([attribute.__id__])
- end
- end
- end
-diff --git a/spec/unit/virtus/attribute_set/element_set_spec.rb b/spec/unit/virtus/attribute_set/element_set_spec.rb
-index 5db7e41..8d9c638 100644
---- a/spec/unit/virtus/attribute_set/element_set_spec.rb
-+++ b/spec/unit/virtus/attribute_set/element_set_spec.rb
-@@ -37,20 +37,28 @@
-
- it { is_expected.to equal(attribute) }
-
-- it 'replaces the original attribute' do
-- expect { subject }.to change { object.to_a }.from(attributes).to([ attribute ])
-+ it "replaces the original attribute object" do
-+ expect { subject }.to change { object.to_a.map(&:__id__) }.
-+ from(attributes.map(&:__id__)).
-+ to([attribute.__id__])
- end
-
-- it 'allows #[] to access the attribute with a symbol' do
-- expect { subject }.to change { object['name'] }.from(original).to(attribute)
-+ it 'allows #[] to access the attribute with a string' do
-+ expect { subject }.to change { object['name'].__id__ }.
-+ from(original.__id__).
-+ to(attribute.__id__)
- end
-
-- it 'allows #[] to access the attribute with a string' do
-- expect { subject }.to change { object[:name] }.from(original).to(attribute)
-+ it 'allows #[] to access the attribute with a symbol' do
-+ expect { subject }.to change { object[:name].__id__ }.
-+ from(original.__id__).
-+ to(attribute.__id__)
- end
-
- it 'allows #reset to track overridden attributes' do
-- expect { subject }.to change { object.reset.to_a }.from(attributes).to([ attribute ])
-+ expect { subject }.to change { object.reset.to_a.map(&:__id__) }.
-+ from(attributes.map(&:__id__)).
-+ to([attribute.__id__])
- end
- end
- end
-diff --git a/spec/unit/virtus/attribute_set/merge_spec.rb b/spec/unit/virtus/attribute_set/merge_spec.rb
-index 72dc39c..9981ece 100644
---- a/spec/unit/virtus/attribute_set/merge_spec.rb
-+++ b/spec/unit/virtus/attribute_set/merge_spec.rb
-@@ -21,12 +21,14 @@
-
- context 'with a duplicate attribute' do
- let(:attributes) { [Virtus::Attribute.build(String, :name => name)] }
-- let(:attribute) { Virtus::Attribute.build(String, :name => name) }
-+ let(:attribute) { Virtus::Attribute.build(String, :name => name) }
-
- it { is_expected.to equal(object) }
-
-- it 'replaces the original attribute' do
-- expect { subject }.to change { object.to_a }.from(attributes).to([attribute])
-+ it "replaces the original attribute object" do
-+ expect { subject }.to change { object.to_a.map(&:__id__) }.
-+ from(attributes.map(&:__id__)).
-+ to([attribute.__id__])
- end
- end
- end
diff --git a/dev-ruby/virtus/metadata.xml b/dev-ruby/virtus/metadata.xml
deleted file mode 100644
index fc67007cce91..000000000000
--- a/dev-ruby/virtus/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">solnic/virtus</remote-id>
- <remote-id type="rubygems">virtus</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ruby/virtus/virtus-1.0.5.ebuild b/dev-ruby/virtus/virtus-1.0.5.ebuild
deleted file mode 100644
index 33a923897c78..000000000000
--- a/dev-ruby/virtus/virtus-1.0.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="Changelog.md CONTRIBUTING.md README.md"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_RECIPE_DOC="yard"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Attributes on Steroids for Plain Old Ruby Objects"
-HOMEPAGE="https://github.com/solnic/virtus https://rubygems.org/gems/virtus"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-PATCHES=( "${FILESDIR}/${P}-equalizer.patch" )
-
-ruby_add_rdepend ">=dev-ruby/axiom-types-0.1
- <dev-ruby/axiom-types-1
- >=dev-ruby/coercible-1.0
- <dev-ruby/coercible-2
- >=dev-ruby/descendants_tracker-0.0.3
- <dev-ruby/descendants_tracker-1
- >=dev-ruby/equalizer-0.0.9
- <dev-ruby/equalizer-1"
-
-ruby_add_bdepend "test? (
- dev-ruby/inflecto
- dev-ruby/bogus
-)"