summaryrefslogtreecommitdiff
path: root/dev-ruby/vcr/vcr-2.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/vcr/vcr-2.9.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/vcr/vcr-2.9.3.ebuild')
-rw-r--r--dev-ruby/vcr/vcr-2.9.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/vcr/vcr-2.9.3.ebuild b/dev-ruby/vcr/vcr-2.9.3.ebuild
new file mode 100644
index 000000000000..5f7a9ea8c29d
--- /dev/null
+++ b/dev-ruby/vcr/vcr-2.9.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CONTRIBUTING.md README.md Upgrade.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Records your test suite's HTTP interactions and replay them during test runs"
+HOMEPAGE="https://github.com/myronmarston/vcr/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm"
+SLOT="2"
+IUSE="test"
+
+# Tests require all supported HTTP libraries to be present, and it is
+# not possible to avoid some of them without very extensive patches.
+RESTRICT="test"