summaryrefslogtreecommitdiff
path: root/dev-ruby/vagrant_cloud
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /dev-ruby/vagrant_cloud
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'dev-ruby/vagrant_cloud')
-rw-r--r--dev-ruby/vagrant_cloud/Manifest2
-rw-r--r--dev-ruby/vagrant_cloud/vagrant_cloud-2.0.2.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/vagrant_cloud/Manifest b/dev-ruby/vagrant_cloud/Manifest
index 855d7ab55ce6..48e02df79f28 100644
--- a/dev-ruby/vagrant_cloud/Manifest
+++ b/dev-ruby/vagrant_cloud/Manifest
@@ -1,3 +1,5 @@
DIST vagrant_cloud-2.0.1.tar.gz 12278 BLAKE2B 9d8bf72809af21e55a6fbfa4c41098a5164c5426ac1d75243f45ed71cc0be8790e06a6b512188683ef1acf2b39faf9d2d72619605ed90c2529eb69b36f4b804a SHA512 98a84200e8e34d0678be6a67872411308c32a8112b1788574baa24bb4bf2e5fd8eab4727f3e2ca56cd8251ff54d14f009145ded8d30a353a581997673a9269cc
+DIST vagrant_cloud-2.0.2.tar.gz 13515 BLAKE2B 3014effb70df8aa7aa793cc75e92e46ceec406e3ad1c30f4cd40e1f05075e3e3b399d5d89424920c7312189b4f48cff82bb8e02f4c30b33a7194c973c365ed79 SHA512 13d56c3090092c6e1b6d47a98e8c21afabfe9fc28ee75b402b91e58869c221821141c4fdba3aaceca8970ae5474fe9a8109513f8dd525fab2cfa3623042d01c8
EBUILD vagrant_cloud-2.0.1.ebuild 727 BLAKE2B 72394b791ad3ddb2174b73fd5a67ef7e99c115cb35b99361797dadaef0d635713cced5391366b0cfbd7b1a93a6814c88fd5faf098d41f84ba9dcc166be4e431a SHA512 76cb776a3d90b7fbaf9b718f7f99e2a580c3a3f93f50eb9b7bf6dd39bdfc64aa0ba6ccee882b89f6ea7d3e2e3f6f7c579b6cc2c3314a63b1877d9b9e08be8525
+EBUILD vagrant_cloud-2.0.2.ebuild 732 BLAKE2B 559ab9e669192fda9ee63c945129e95a042a2499bb4033100f52eec5f6b2f8a64a7efc2ac92c46647053084a5342c2fe443dab38e8a9ec5da627ce38c8c66511 SHA512 6ebb813d5cc2f0e8db838906a1994ffefce83e757128836c40913432c9570b46e25aa985219eb00d217a123f6e662eaa2c88dfbda0a0051bcc7c855a43c0ece7
MISC metadata.xml 339 BLAKE2B 1b57cdf6e4d8901fcad56c7083bf38440bb7ab26cfdb629ae4f77cd0f68dad37497ed7a1bcdb74378bafea1122122443685a23834382c6030b7a71f8400aa9bc SHA512 c85b172d220ce7a3742bf021789ec5e2dc2d2d0630f30dd033062588179002e4101f0deda913aa8727486f412ddda3560353bbd56b77e7ddbcfc370c9fbf0c37
diff --git a/dev-ruby/vagrant_cloud/vagrant_cloud-2.0.2.ebuild b/dev-ruby/vagrant_cloud/vagrant_cloud-2.0.2.ebuild
new file mode 100644
index 000000000000..933e6187e6d2
--- /dev/null
+++ b/dev-ruby/vagrant_cloud/vagrant_cloud-2.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Vagrant Cloud API Library"
+HOMEPAGE="https://github.com/hashicorp/vagrant_cloud"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rest-client-2.0.2"
+ruby_add_bdepend ">=dev-ruby/rake-10.4
+ test? ( >=dev-ruby/webmock-3.0 )"
+
+all_ruby_prepare() {
+ sed -i -e '/rubocop/I s:^:#:' Rakefile || die
+}