summaryrefslogtreecommitdiff
path: root/dev-ruby/uuidtools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/uuidtools
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/uuidtools')
-rw-r--r--dev-ruby/uuidtools/Manifest3
-rw-r--r--dev-ruby/uuidtools/metadata.xml14
-rw-r--r--dev-ruby/uuidtools/uuidtools-2.1.5-r1.ebuild35
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/uuidtools/Manifest b/dev-ruby/uuidtools/Manifest
new file mode 100644
index 000000000000..a800d2ecf584
--- /dev/null
+++ b/dev-ruby/uuidtools/Manifest
@@ -0,0 +1,3 @@
+DIST uuidtools-2.1.5.gem 25600 BLAKE2B 8219d559d92d86e7a87b97d4eda9454b6c203f89beb4a74ff619f51470d339c4063b1982ffb6f8acd5b9c206ac7d0dc537e968b1744a030a4f6cd629a358fc7a SHA512 c56e6329e48638bd5049d348beedec7fadb9ee7a133a5013ddd41ae98baa8213d8944903059729c9ca4f38b24d9b565b5653332685982337a4233f11d4865ac0
+EBUILD uuidtools-2.1.5-r1.ebuild 1068 BLAKE2B 23f30a49acdff07929b471b2f9639a6547ef9eff52335129a1ada591442e8a9b3138c8ed4d663342bc00487292f8c2389064f731e0c103e8f97047690a7510ba SHA512 9d49436c07fabfcb1a291fcce7ea0b8ff2f5436fd59f716668ce50519bd5ac813928af1a9045fd7857132cc4ad739244b45f8107742d5bee3096313299d45970
+MISC metadata.xml 539 BLAKE2B 5a99e5c959879b57b6b604bd90b1e7c91fbee2608653e4a6b6cb135012f5c964a1b07ff90f9f8702c99a639df9a143c308722df4c0bcd1e8beea2259d3e9fc39 SHA512 6f697164bc069b62ade929d31fda162c1d25e33fedc1135985cad7bdc80d256db169aa8ee3f2293a9dc56667a1e1d4f75834ca1d4b3c3310e3b26ed85079f09e
diff --git a/dev-ruby/uuidtools/metadata.xml b/dev-ruby/uuidtools/metadata.xml
new file mode 100644
index 000000000000..5ff607a30251
--- /dev/null
+++ b/dev-ruby/uuidtools/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <longdescription lang="en">Simple Ruby library for the generation of UUID, based on constant,
+ time-based or random data. It conforms to RFC 4122 whenever
+ possible.</longdescription>
+ <upstream>
+ <remote-id type="github">sporkmonger/uuidtools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/uuidtools/uuidtools-2.1.5-r1.ebuild b/dev-ruby/uuidtools/uuidtools-2.1.5-r1.ebuild
new file mode 100644
index 000000000000..2f0df9781742
--- /dev/null
+++ b/dev-ruby/uuidtools/uuidtools-2.1.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="-f tasks/yard.rake doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple library to generate UUIDs"
+HOMEPAGE="https://github.com/sporkmonger/uuidtools"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-macos"
+IUSE="doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Avoid specs that require an actual network interface to get a MAC
+ # address. We can't assume that a network interface is available.
+ sed -e '/when obtaining a MAC address/,/^end/ s:^:#:' \
+ -i spec/uuidtools/mac_address_spec.rb || die
+ sed -e '/should correctly generate timestamp variant UUIDs/,/^ end/ s:^:#:' \
+ -i spec/uuidtools/uuid_creation_spec.rb || die
+ sed -e '/should not treat a timestamp version UUID as a random node UUID/,/^ end/ s:^:#:' \
+ -i spec/uuidtools/uuid_parsing_spec.rb || die
+}