summaryrefslogtreecommitdiff
path: root/dev-ruby/unicode-display_width
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-02 11:46:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-02 11:46:02 +0100
commitfade240e5eae2521e59569af4ab63e27415f4e5b (patch)
tree18ce5cd3bed52f77d3ff5fbe8b47a025b6892619 /dev-ruby/unicode-display_width
parent16c48ec5caa018c82b1db0f23542c29893f9b919 (diff)
gentoo auto-resync : 02:10:2023 - 11:46:02
Diffstat (limited to 'dev-ruby/unicode-display_width')
-rw-r--r--dev-ruby/unicode-display_width/Manifest2
-rw-r--r--dev-ruby/unicode-display_width/unicode-display_width-2.5.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/unicode-display_width/Manifest b/dev-ruby/unicode-display_width/Manifest
index a20b19bfb622..6ee68a134a5d 100644
--- a/dev-ruby/unicode-display_width/Manifest
+++ b/dev-ruby/unicode-display_width/Manifest
@@ -1,5 +1,7 @@
DIST unicode-display_width-1.7.0.tar.gz 10822 BLAKE2B c3db387b9d61ba4ea9d5559824b22e40f173f9e9bcf7fdad3dba1edc36b39ae90276818bd54e74a6731bd2cb8c48b28e440d07f7e3cedbd8dc13441f79a2b56c SHA512 2b6d2b0118f4a2ad69e98fe2fac611ca94adc0dc59ad076083d0243c630a81a01d650965149a25feaf8986c262a5d55294e064361420e2140b53c5ced5fb1c77
DIST unicode-display_width-2.4.2.tar.gz 13096 BLAKE2B 89f7f8ded131a6c049242ede8822475c2629e2377a6b06ca59b1264c1c18981039c95c0aea8a24c00488b8f5c48aed3cc1b5672785eb36bbcf3cee1af8c2cc53 SHA512 c0815c19821855fed2d3205a6cae2059e0338fb27148f55281c910b54d5b0be2d34ba4bf990ba1c328c454f7ec8dbc0c69427550f2d62d1ac4ce5174b53b8ff3
+DIST unicode-display_width-2.5.0.tar.gz 13115 BLAKE2B 93d50190346409b3ba0dc23cbce841cabab7584f07a5b152851e40fd06168ff26a38c4872aed994e1a77292cf04de31f54075ad6b4329975fd93c30d9afe38b3 SHA512 cd6302136e5d61e6209bd9c6eb432c09d562b59a6a02868a3343a5968c56239cff0f547ed5bed15d5a6a06265385a6a499b148e59f9b84778241c9f8c5efa2be
EBUILD unicode-display_width-1.7.0-r1.ebuild 756 BLAKE2B 3c70be3449e1f039df3b7e705978927cfb219ef285535ba81a5761bd48f79f3b0e66d2636caaf7ec18a270deececa965d546f3545c5d8d794ef0e15115b1d56d SHA512 e703d4e790c4060754608bc6527e22b144bfedffff15a98feccd521cce8848f9c6387edb3334013c8c413a0e9979fc029decdfd4cd6cfc88b18a1c9d52d2ebbc
EBUILD unicode-display_width-2.4.2.ebuild 808 BLAKE2B 297d97fe068363b0b9c85fc56a49291cd3f53e7e2f018a5b87645705a56405d6ae4e8d1245bc0e46ff81f093733a1844cd65b1064c328af06a1a90f86f1abc84 SHA512 e93b77b47f1761a73f089ed8c8926fac8705754988476d290857f68f01a325ed54ac2f88e80c587f1c45ff087d77bf0150d86fa1538d244e8c5423972d2ac4f1
+EBUILD unicode-display_width-2.5.0.ebuild 794 BLAKE2B 3898437dd5d332533af74a46cdb9ebd867b259a9438c6d8c0ddec62deabd03099d63f4cd7fa0b79006dea0a7cf535e8219fe7dccdb2a1cb37578d8173f8ae103 SHA512 3f011b45f2fd00ee51c4f8479dcdd72c46dd145c8699b5ae4d4a9c9d287741aba4b533e49f2b48cbd014395788008e86f25b402c543d077e26d700a6e6402651
MISC metadata.xml 422 BLAKE2B 822ec564698366cc9ae3c5319faf86ab7e3408f7f48cb1fe7118a912469bfa75119d1a64fd01dab709cf6df99ef5a5f0300a60393b77ccce0081e321e32515fe SHA512 d7c6abeb16d32bca8afa485954bd4fea6e4212c1d9b8139346c2d072cb008884a5bb70a82653a2e678a5416930a5e01b65de92534e13195edf3b9449e70f3ae6
diff --git a/dev-ruby/unicode-display_width/unicode-display_width-2.5.0.ebuild b/dev-ruby/unicode-display_width/unicode-display_width-2.5.0.ebuild
new file mode 100644
index 000000000000..566cc9a8e3fc
--- /dev/null
+++ b/dev-ruby/unicode-display_width/unicode-display_width-2.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_GEMSPEC="unicode-display_width.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds String#display_width to get the display size using EastAsianWidth.txt"
+HOMEPAGE="https://github.com/janlelis/unicode-display_width"
+SRC_URI="https://github.com/janlelis/unicode-display_width/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid experimental emoji support for now
+ sed -e '/\[emoji\]/,/^ end/ s:^:#:' \
+ -e '/Config object based API/,/^end/ s:^:#:' \
+ -i spec/display_width_spec.rb || die
+}