summaryrefslogtreecommitdiff
path: root/dev-ruby/uconv/uconv-0.6.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/uconv/uconv-0.6.1-r3.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/uconv/uconv-0.6.1-r3.ebuild')
-rw-r--r--dev-ruby/uconv/uconv-0.6.1-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/uconv/uconv-0.6.1-r3.ebuild b/dev-ruby/uconv/uconv-0.6.1-r3.ebuild
new file mode 100644
index 000000000000..8af5f475d2da
--- /dev/null
+++ b/dev-ruby/uconv/uconv-0.6.1-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+inherit ruby-ng
+
+DESCRIPTION="A module to convert ISO/IEC 10646 (Unicode) string and Japanese strings"
+HOMEPAGE="http://www.yoshidam.net/Ruby.html#uconv"
+SRC_URI="http://www.yoshidam.net/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S=${PN}
+
+all_ruby_prepare() {
+ sed -i -e '/^\$CFLAGS = ""/d' extconf.rb || die "Unable to remove CFLAGS line"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_install() {
+ emake V=1 DESTDIR="${D}" install
+}
+
+all_ruby_install() {
+ dodoc README*
+}