summaryrefslogtreecommitdiff
path: root/dev-ruby/tzinfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/tzinfo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/tzinfo')
-rw-r--r--dev-ruby/tzinfo/Manifest5
-rw-r--r--dev-ruby/tzinfo/metadata.xml8
-rw-r--r--dev-ruby/tzinfo/tzinfo-1.2.4.ebuild32
-rw-r--r--dev-ruby/tzinfo/tzinfo-1.2.5.ebuild32
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-ruby/tzinfo/Manifest b/dev-ruby/tzinfo/Manifest
new file mode 100644
index 000000000000..e2f1ef3105ae
--- /dev/null
+++ b/dev-ruby/tzinfo/Manifest
@@ -0,0 +1,5 @@
+DIST tzinfo-1.2.4.gem 152576 BLAKE2B c6815fc7277153c5e00ea2359845df25affab5a08f9274729254662e056de702613f4b8ca5b4f2ddcd756d86ae12e534a4e2a5a4661f361ef1d59cb3d7f07bfa SHA512 0b983aa6b4fdbb3c49329bb51394f1edbeb6f4d216d108448aa9dce751dbc2e348d58032cb41df78a3d249611770e9e345a4d0041597ceadf052b863c3e6d1ab
+DIST tzinfo-1.2.5.gem 153600 BLAKE2B 3df5625c61eabf94bb457381ac7d0cdebd5b55da3bb043fe58063cccccb623b502e026a71faef4f7d7efe75eae2fdfd0bf3e0b97a3763fec9a1018f0c6c2ae0f SHA512 87f7cd66d6e80d51d216cb993cc76fe7758db03ffd39dde96eb24a9d208699766a8dbff048485fb732ce125ee9f971e38ed9ee1197f3ee3fc3ee8a8da840dd45
+EBUILD tzinfo-1.2.4.ebuild 908 BLAKE2B 0486b70c633ef9b0f28b7040f7aa67d4b4cfd6ce127a57aaa0ff7ef2300680781fe6d46c6c2dc8c9b6f335a195731b4d630617fc422adf2291cb6f8956516d20 SHA512 679353489084cb2e4fc00d6a69eaf62763c976d113c9f5b1135040dfa98b57e1ce85208ad2b63d71a09593fda13c1c07aff67b938c2d25b4d2e35fd723bfe3bc
+EBUILD tzinfo-1.2.5.ebuild 919 BLAKE2B 7467074806aefab30b16f6adf11a4f88baa34f1fede9af1d3f9111b7eb518f473c866976a63a98e871a7355feb963ec4b781d5643c58ff0e3d3d9aae42e4baa8 SHA512 8c1a91ea92bb1451d99fdf4978069acc0f688f7e4e55f13811cd2896972063298bf42139cea70ff3174ce572f69e4404dc708bdcf7ae14792228940be8583204
+MISC metadata.xml 251 BLAKE2B e8bf2b70161d425791d65052583fd8be03b19ef3bb2a2cde34605bc93224fea9d8c6a91f0f2d630a00094ef54c0871e210da0e0134f52401bc80cb6b2358c13d SHA512 17d4dbd64468a524311a24ca065537a5b21560388efd282f3fa873e6722f70db6f83e3e5615556450905c29d5df2cf0a0855f9c0b38bf23f0f8112501456d4ea
diff --git a/dev-ruby/tzinfo/metadata.xml b/dev-ruby/tzinfo/metadata.xml
new file mode 100644
index 000000000000..eb1e47f2edfb
--- /dev/null
+++ b/dev-ruby/tzinfo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/tzinfo/tzinfo-1.2.4.ebuild b/dev-ruby/tzinfo/tzinfo-1.2.4.ebuild
new file mode 100644
index 000000000000..c3dee166a1bb
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-1.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="test_zoneinfo"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="https://tzinfo.github.io/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ppc ~ppc64 x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/timezone-data"
+DEPEND="test? ( sys-libs/timezone-data )"
+
+ruby_add_rdepend ">=dev-ruby/thread_safe-0.1:0"
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+}
diff --git a/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild b/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild
new file mode 100644
index 000000000000..d0d98be91102
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-1.2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST="test_zoneinfo"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="https://tzinfo.github.io/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/timezone-data"
+DEPEND="test? ( sys-libs/timezone-data )"
+
+ruby_add_rdepend ">=dev-ruby/thread_safe-0.1:0"
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+}