summaryrefslogtreecommitdiff
path: root/dev-ruby/tzinfo/tzinfo-1.2.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ruby/tzinfo/tzinfo-1.2.8.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ruby/tzinfo/tzinfo-1.2.8.ebuild')
-rw-r--r--dev-ruby/tzinfo/tzinfo-1.2.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/tzinfo/tzinfo-1.2.8.ebuild b/dev-ruby/tzinfo/tzinfo-1.2.8.ebuild
new file mode 100644
index 000000000000..516750d24591
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-1.2.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="test_zoneinfo"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="https://tzinfo.github.io/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/timezone-data"
+DEPEND="test? ( sys-libs/timezone-data )"
+
+ruby_add_rdepend ">=dev-ruby/thread_safe-0.1:0"
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Avoid taint tests that throw SecurityErrors on newer ruby versions.
+ sed -i -e '/_info_tainted/askip"SecurityError"' test/tc_ruby_data_source.rb || die
+}