summaryrefslogtreecommitdiff
path: root/dev-ruby/tty-which
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-ruby/tty-which
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-ruby/tty-which')
-rw-r--r--dev-ruby/tty-which/Manifest2
-rw-r--r--dev-ruby/tty-which/tty-which-0.4.2.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/tty-which/Manifest b/dev-ruby/tty-which/Manifest
index 07ec1870f7c0..f7cc2cce433b 100644
--- a/dev-ruby/tty-which/Manifest
+++ b/dev-ruby/tty-which/Manifest
@@ -1,3 +1,5 @@
DIST tty-which-0.4.1.gem 11264 BLAKE2B 540249aaeaa5458fef3572413cf673e04765c1ad41971ac3f9bd930a42855459db6c6f8f47c90ee1021993161db6a399ba6edd0384da7db91da999550d3e733b SHA512 e48b284abb3e4177b9f04acec5202a70d3fcaa2d477444c5a9d9920ac00eb192656bc48ca33d72c26845b415a0a90e907dab1dd35608b62bc8e4b1b1b25af51c
+DIST tty-which-0.4.2.tar.gz 9820 BLAKE2B 07ac2aa7a3e42127f456045fbdb92db2ea9834b08e0fccbe81767e01817ec2bf7304fb8a41408b0c4da8ecba3caf8bc236de9cb5637c6f197fe3835d0e9b231e SHA512 573b4ed1bfd4dd66dc3337d076a6559bda57b76c95c75f1aeef8bb6d4e0c81ef72057f5ef0521a10afb2a550b8850e6311aaa56ef2499146221f33403621ee54
EBUILD tty-which-0.4.1.ebuild 504 BLAKE2B e4c9fc62b162655cdead13e5a499ffd5dd92727890245a10bde55eb951910426da783ca3018bc17546e210f8374e0eb77d80e64fe620a860f6ae785b061c51aa SHA512 157233a369734d3a000228f13b9b3993d2cb70b68b973ce89e099bae68abd7c0f843f28c2a894d14607826c9189962f497822d49b33f61ba1c99bdf461d2955e
+EBUILD tty-which-0.4.2.ebuild 1056 BLAKE2B 73268e248573fd70bb1d9779082e308c0c289803116beca8dcbe07698352f39366f7698da11b0209a67b9f368fda7546eebc6cf747fb05efb158bd95748f1197 SHA512 0555bcdda7c07587635888825ec829041754f55c11e82a2404d3c27f7b57be13dd31e58d9eff1370d5a9b20d9c97667bffa77b2f654c5ba9ea52ca80da9da294
MISC metadata.xml 337 BLAKE2B 123637d7c276f3090c739e2a3823bb32dda76b1d375d81da3b7577c597a5358957381f5bfeb0379abef336ec70572a3cbfd04adf1a279a51e1783a7ade883601 SHA512 44af181aeb529b6fcbc3d5f07dcfb88b6b7d161f0d6be57be3c09a2d22a9cdc32b0c281f4336efa645daa7951799387ab899765e33823f34138b29e979887ae2
diff --git a/dev-ruby/tty-which/tty-which-0.4.2.ebuild b/dev-ruby/tty-which/tty-which-0.4.2.ebuild
new file mode 100644
index 000000000000..bf34ebfeffa4
--- /dev/null
+++ b/dev-ruby/tty-which/tty-which-0.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="tty-which.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Platform independent implementation of Unix which command"
+HOMEPAGE="https://github.com/piotrmurach/tty-which"
+SRC_URI="https://github.com/piotrmurach/tty-which/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Fix running specs without bundler, fixed upstream
+ sed -e 's/receive(:join)$/receive(:join).and_call_original/' \
+ -e '96iallow(::File).to receive(:join).and_call_original' \
+ -e '115iallow(::File).to receive(:join).and_call_original' \
+ -i spec/unit/which_spec.rb || die
+ sed -e '5iallow(::File).to receive(:join).and_call_original' \
+ -i spec/unit/executable_file_spec.rb || die
+}