summaryrefslogtreecommitdiff
path: root/dev-ruby/tty-which/tty-which-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
commit616579b5d773c50af31ee56f00105d96ce641ca2 (patch)
tree2ad4d3ba1429bd93a36ab99a2f5ec3490412115e /dev-ruby/tty-which/tty-which-0.5.0.ebuild
parent068424b26532f3551a81421a9be67ed206e5c11a (diff)
gentoo resync : 14.08.2021
Diffstat (limited to 'dev-ruby/tty-which/tty-which-0.5.0.ebuild')
-rw-r--r--dev-ruby/tty-which/tty-which-0.5.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/tty-which/tty-which-0.5.0.ebuild b/dev-ruby/tty-which/tty-which-0.5.0.ebuild
new file mode 100644
index 000000000000..2bd6b2425e01
--- /dev/null
+++ b/dev-ruby/tty-which/tty-which-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="tty-which.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Platform independent implementation of Unix which command"
+HOMEPAGE="https://github.com/piotrmurach/tty-which"
+SRC_URI="https://github.com/piotrmurach/tty-which/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Fix running specs without bundler, fixed upstream
+ sed -e 's/receive(:join)$/receive(:join).and_call_original/' \
+ -e '96iallow(::File).to receive(:join).and_call_original' \
+ -e '115iallow(::File).to receive(:join).and_call_original' \
+ -i spec/unit/which_spec.rb || die
+ sed -e '5iallow(::File).to receive(:join).and_call_original' \
+ -i spec/unit/executable_file_spec.rb || die
+}