summaryrefslogtreecommitdiff
path: root/dev-ruby/tty-prompt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ruby/tty-prompt
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ruby/tty-prompt')
-rw-r--r--dev-ruby/tty-prompt/Manifest2
-rw-r--r--dev-ruby/tty-prompt/tty-prompt-0.20.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/tty-prompt/Manifest b/dev-ruby/tty-prompt/Manifest
index 3714a72940f4..b5ce8f86e223 100644
--- a/dev-ruby/tty-prompt/Manifest
+++ b/dev-ruby/tty-prompt/Manifest
@@ -1,3 +1,5 @@
DIST tty-prompt-0.19.0.gem 71680 BLAKE2B 67da3c428fa5ab602fa4735d06115ba5bab53f06d43109fa06810e538cafae5486767f41927fc77616e608278a0f955659734704c9536b40e87682e6f0e5718b SHA512 958263a7b3b7cfbac2877d81878b324fe53bc258be36749597f959085643e50247651bf48fceff4bf1098b68cf47dae68f30173e45585bfdbf7126959387427a
+DIST tty-prompt-0.20.0.gem 72704 BLAKE2B c3a24544459bfd70aa1ada029211d8873665794ac0dfa19bd02c86e3104c937aefc50009763ccacc3b3eb7c91b220125279c4388a94cd4dab5bc2cb77bad701e SHA512 d3e018465779d673bb80d15f2706edd762236dbee37bc9bd090138fb5dd918c63c4cda3418054391b9d15032fde399911e50c6fbed9d8063afc5896b31fb3fb1
EBUILD tty-prompt-0.19.0.ebuild 604 BLAKE2B 8c3cf65b0b1eda1e552d9b223a4a5b5650e8db850ad38acb552fbcef943e59ddc16a76560a7cbdd0cdd38117b8c714ddfc7f93b1dd408f8b11849e8901daa52b SHA512 aadf2eb5360be2d5bb104c0f9a6edd0a37a33a3a0d6fa2b45c02c1aa8be1ea9fbd5c24994255fba78f1e03fe65959458b0e951bcb09b5b79770d165a628d33cb
+EBUILD tty-prompt-0.20.0.ebuild 604 BLAKE2B 4ad825cdeb6c476bb1bfa23ba4519bce927089ebe9f4a8bf7c97c81b3c35b670095aa7a8fb825140aef527c4a2afc21386ae72e7dd3f8068c1492b13512465bf SHA512 a3289054a294a48d4821e32aa3e6c65d3821655628c649083370be5bc7d3ed0359393e9d32c063a793c5bcdea7bcc98dd97241816c72f5b8aa6e4e74df0db551
MISC metadata.xml 338 BLAKE2B 6162c739121dfed6f95cefbcd4b187668bcc434678ed094b70d9963662ab44e263e357ed1c3ad51bde318509dd19dabb7e8acd26845bfc1bad1119d2a6c27964 SHA512 383567b446b991c346809d57da8c2dc269d5dee34abc0a7ec354942ac025fc868cd0d2b92ebb764d7d2aa8a4b0f86ecc5bf00c80619922cb694fe0e04445d12b
diff --git a/dev-ruby/tty-prompt/tty-prompt-0.20.0.ebuild b/dev-ruby/tty-prompt/tty-prompt-0.20.0.ebuild
new file mode 100644
index 000000000000..60974d95f5d4
--- /dev/null
+++ b/dev-ruby/tty-prompt/tty-prompt-0.20.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A beautiful and powerful interactive command line prompt"
+HOMEPAGE="https://github.com/piotrmurach/tty-prompt"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/necromancer-0.5*
+ =dev-ruby/pastel-0.7*
+ =dev-ruby/tty-reader-0.7*
+"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}