summaryrefslogtreecommitdiff
path: root/dev-ruby/tty-cursor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-ruby/tty-cursor
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-ruby/tty-cursor')
-rw-r--r--dev-ruby/tty-cursor/Manifest2
-rw-r--r--dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/tty-cursor/Manifest b/dev-ruby/tty-cursor/Manifest
index 95f2993c0f56..a21df4798130 100644
--- a/dev-ruby/tty-cursor/Manifest
+++ b/dev-ruby/tty-cursor/Manifest
@@ -1,3 +1,5 @@
DIST tty-cursor-0.7.0.gem 11776 BLAKE2B 5dea8f2bde63f803639b4300bf3a8b22a89de7a20530ede38f75bdae7fbb522fe70adb0c78e20cc45e8001dba9fb378722f9fce6d26a68c0af00b7bc98a62a96 SHA512 00de195ba183174ebd10da7f1fdbb436a17fe9befc6eacb2d4cf4b1505be2c7d0719c0dc32d75a82900b2252ffbed00219ce31836c442b63c267e26dad40da63
+DIST tty-cursor-0.7.1.tar.gz 11015 BLAKE2B 222602d7dd3ef2372555913dc59bdd4b4965ac5c3601268d0f77060835d4ae9bc9fa23d54f811e7c0a453b80786d4ef07e0bd26cc8d76f6b963787a04b17569b SHA512 7c1f664bfb3c8c46aab08cb3806b8a00d92b45195fae47e851967f88040cc64d598bdd80e37f782be83fa60dff82c607d93026ffbf003125fea8230f4e18639e
EBUILD tty-cursor-0.7.0.ebuild 528 BLAKE2B 7ebe22cfd7979df24047aa10048afe11f261c62a6d77fd181f9a092e2e0f92b3b69c479b9920d674f7644df2c1ab2785b67f0873541a75e9276b51db0d72075a SHA512 c81a3ed96c8fc47c2d1c6d03a4406cd92440240b372cffcb3a67288d625dbafcfb80c3a2f201a429a9d5743bcf92e9a910df99f4e4d1d8b3db1d37636d15aad8
+EBUILD tty-cursor-0.7.1.ebuild 739 BLAKE2B d7b8b1f028a8cc742b8fa5039e757c6ae3bf6f8e1b475b84d4540c85547748a4f3677066df53663bd869c3879529e5e46f0c643a977ff40048cdd76d19bb3fbc SHA512 03f5817f4e0c00ee5379a616b6e074224926f6eaf51326454e7123b187b0bf56866664527eb034abbfdedd5fc22ec581d74d62533bef43df86ed0621f5c87f3c
MISC metadata.xml 338 BLAKE2B 45f23e16fa65a93c490d600cf878a1ca15d22fc6ee4945a1fbb260e2534a3585bbb3eb4d483e3206aa9b3d4e555cd3c9fab1cf3f259e29f726c31395683fd2b6 SHA512 58e209eb6d1e1762dd409adcd4aefbc0afefcaeee160307d6ec02bf6c0c72b8dca516fdac1c6b8b65f33da43cd82cc01be38d76abe84ee22555b47d80f2fa9ba
diff --git a/dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild b/dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild
new file mode 100644
index 000000000000..db36fec431af
--- /dev/null
+++ b/dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="tty-cursor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Move the terminal cursor around and manipulate text using intuitive method calls"
+HOMEPAGE="https://github.com/piotrmurach/tty-cursor"
+SRC_URI="https://github.com/piotrmurach/tty-cursor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+
+ sed -i -e 's:require_relative ":require "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}