summaryrefslogtreecommitdiff
path: root/dev-ruby/trollop/trollop-2.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/trollop/trollop-2.1.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/trollop/trollop-2.1.2.ebuild')
-rw-r--r--dev-ruby/trollop/trollop-2.1.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/trollop/trollop-2.1.2.ebuild b/dev-ruby/trollop/trollop-2.1.2.ebuild
new file mode 100644
index 000000000000..a160e2ba8416
--- /dev/null
+++ b/dev-ruby/trollop/trollop-2.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Trollop is a commandline option parser for Ruby"
+HOMEPAGE="http://manageiq.github.io/trollop/"
+LICENSE="MIT"
+
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="2"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/chronic )"
+
+each_ruby_test() {
+ MUTANT=true ${RUBY} -Ilib:test test/test_trollop.rb || die "Tests failed."
+}