summaryrefslogtreecommitdiff
path: root/dev-ruby/tokyocabinet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/tokyocabinet
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/tokyocabinet')
-rw-r--r--dev-ruby/tokyocabinet/Manifest3
-rw-r--r--dev-ruby/tokyocabinet/metadata.xml8
-rw-r--r--dev-ruby/tokyocabinet/tokyocabinet-1.32.0.ebuild35
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/tokyocabinet/Manifest b/dev-ruby/tokyocabinet/Manifest
new file mode 100644
index 000000000000..049e6e8c6a3a
--- /dev/null
+++ b/dev-ruby/tokyocabinet/Manifest
@@ -0,0 +1,3 @@
+DIST tokyocabinet-1.32.0.gem 18944 BLAKE2B d55ebba43bfb904dfe2b18bc0c22e92b30ced4cdbda8025f7e4d9088da03a2c8486f210473bd05be13fa8d8448830a8f11fc9dc9c34b9803514fd8fc5cce984c SHA512 274a72e166bfb776b66379f587a141c8d0407dec7aa17bcd2e1ce2a401784f52433e72bc356140f69dcca651351edb22d5c9da6fec09b1b1fcfd53cb5af666f3
+EBUILD tokyocabinet-1.32.0.ebuild 582 BLAKE2B 64fa40aa38e17a6cbea8b87fa09ea1940e220b6d42033456dd825406624aab3c9e316d545d6c51e5f3ed407810439487291c899cb5414c268d82109e9c621ae5 SHA512 ec4789846e6bceb532766cfe2f8f653f7074b1121dc2cff754e3ebb5d31c198e4560b1e898cc6f3e27f966f2270112275062db4f17eff41c705f1d787e8af9bd
+MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/tokyocabinet/metadata.xml b/dev-ruby/tokyocabinet/metadata.xml
new file mode 100644
index 000000000000..28ab0c15f206
--- /dev/null
+++ b/dev-ruby/tokyocabinet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/tokyocabinet/tokyocabinet-1.32.0.ebuild b/dev-ruby/tokyocabinet/tokyocabinet-1.32.0.ebuild
new file mode 100644
index 000000000000..0d9f0771410b
--- /dev/null
+++ b/dev-ruby/tokyocabinet/tokyocabinet-1.32.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for Tokyo Cabinet"
+HOMEPAGE="http://fallabs.com/tokyocabinet/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND+="dev-db/tokyocabinet"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_install() {
+ emake install DESTDIR="${D}"
+
+ each_fakegem_install
+}