summaryrefslogtreecommitdiff
path: root/dev-ruby/timers/timers-4.3.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-12 11:41:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-12 11:41:02 +0100
commitd15be4fe2ff3e70717117a938dbe5a11cec60a7b (patch)
tree11b55e9435c5d885c195338bb42507d74636c34c /dev-ruby/timers/timers-4.3.5-r1.ebuild
parent81663ab80e0e0c5839b216934509b6bcbf08429a (diff)
gentoo auto-resync : 12:04:2023 - 11:41:02
Diffstat (limited to 'dev-ruby/timers/timers-4.3.5-r1.ebuild')
-rw-r--r--dev-ruby/timers/timers-4.3.5-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/timers/timers-4.3.5-r1.ebuild b/dev-ruby/timers/timers-4.3.5-r1.ebuild
new file mode 100644
index 000000000000..35732c62e28d
--- /dev/null
+++ b/dev-ruby/timers/timers-4.3.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="timers.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="sus"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby one-shot and periodic timers"
+HOMEPAGE="https://github.com/socketry/timers"
+SRC_URI="https://github.com/socketry/timers/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+PATCHES=(
+ # https://github.com/socketry/timers/issues/82
+ "${FILESDIR}"/${P}-timers-slow.patch
+)
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid performance-based tests since we cannot guarantee specific performance levels.
+ rm -f test/timers/performance.rb || die
+}