summaryrefslogtreecommitdiff
path: root/dev-ruby/timeout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ruby/timeout
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ruby/timeout')
-rw-r--r--dev-ruby/timeout/Manifest3
-rw-r--r--dev-ruby/timeout/metadata.xml11
-rw-r--r--dev-ruby/timeout/timeout-0.2.0.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/timeout/Manifest b/dev-ruby/timeout/Manifest
new file mode 100644
index 000000000000..ebd8f46e363f
--- /dev/null
+++ b/dev-ruby/timeout/Manifest
@@ -0,0 +1,3 @@
+DIST timeout-0.2.0.tar.gz 15672 BLAKE2B 2a42efb4475047c947ec1a30637e4ddb8d745651d9d277af9149f952ee88cda335818156d777db283660ac16f338ac53776f6267f040b115078fed9572b4ddc7 SHA512 fe665127e90782602dc4e0f61b8ea39b3c2092a50a0d5f708fcb14bec08443868dd8539417c29166dd925389ef2beed49a67f16bb195cf998104b7121f4c1c4d
+EBUILD timeout-0.2.0.ebuild 854 BLAKE2B 943e9d5a149bf6016aa9d60e1cc21620ba06b2df5d9b605bc37574ff5d74990e804b76051e8be7027a97fe9e800b7feec34efc4a0915cf92badfab90e537c0ce SHA512 92d17c427da57fadfa2a7baf3bfcf43e46320b8560941477414d27c8a06541f4ed048b9cdb394801edb0b07ec4d079171620a180b0c97d20e3090c1cb780603a
+MISC metadata.xml 339 BLAKE2B 631c72fbacd33d4ff5bae080f6c0c30c59f241e045056f8e4cd8330869a682cc4bdad6c13757f7f151f9171277a3ff227decbb87a20b2a4da7f83ad12d4259e1 SHA512 bff9f7fad39a8eb72caac724534d0d183da7aa43a4f57011e823a4d0b68d53418f858859aff22d46db2b6df3223309322837d2dd2badb0c1eba965cbb1fb3d29
diff --git a/dev-ruby/timeout/metadata.xml b/dev-ruby/timeout/metadata.xml
new file mode 100644
index 000000000000..632f98915b47
--- /dev/null
+++ b/dev-ruby/timeout/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/timeout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/timeout/timeout-0.2.0.ebuild b/dev-ruby/timeout/timeout-0.2.0.ebuild
new file mode 100644
index 000000000000..eb9c7a18c1c5
--- /dev/null
+++ b/dev-ruby/timeout/timeout-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="timeout.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a framework for message digest libraries"
+HOMEPAGE="https://github.com/ruby/timeout"
+SRC_URI="https://github.com/ruby/timeout/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}