summaryrefslogtreecommitdiff
path: root/dev-ruby/timecop/timecop-0.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-29 15:53:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-29 15:53:38 +0100
commit822a054dd1bab7f8080ccd486398034b4ff0b97d (patch)
treec64bfd54aca68af69ccf06b1a9d20365383e3ccc /dev-ruby/timecop/timecop-0.9.4.ebuild
parentf7436a5ce1c11f1c33cd09dd757f768cd07b19fd (diff)
gentoo auto-resync : 29:03:2023 - 15:53:38
Diffstat (limited to 'dev-ruby/timecop/timecop-0.9.4.ebuild')
-rw-r--r--dev-ruby/timecop/timecop-0.9.4.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-ruby/timecop/timecop-0.9.4.ebuild b/dev-ruby/timecop/timecop-0.9.4.ebuild
deleted file mode 100644
index 47d2f9d9ab2f..000000000000
--- a/dev-ruby/timecop/timecop-0.9.4.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.markdown"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
-HOMEPAGE="https://github.com/travisjeffery/timecop"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 ~riscv sparc x86"
-IUSE=""
-
-# Missing testdep activesupport
-ruby_add_bdepend "test? ( dev-ruby/mocha )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' -e '/History.rdoc/d' Rakefile test/test_helper.rb || die
- sed -i -e '/rubygems/ a\gem "test-unit"' \
- -e '/minitest\/rg/ s:^:#:' -e '/pry/ s:^:#:' test/test_helper.rb || die
- # FIXME after activesupport gained ruby22 support
- rm test/time_stack_item_test.rb || die
-}
-
-each_ruby_test() {
- for f in test/*_test.rb ; do
- ${RUBY} -Ilib $f || die
- done
-}