summaryrefslogtreecommitdiff
path: root/dev-ruby/time
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-ruby/time
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-ruby/time')
-rw-r--r--dev-ruby/time/Manifest3
-rw-r--r--dev-ruby/time/metadata.xml11
-rw-r--r--dev-ruby/time/time-0.2.0.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/time/Manifest b/dev-ruby/time/Manifest
new file mode 100644
index 000000000000..95d0c98197aa
--- /dev/null
+++ b/dev-ruby/time/Manifest
@@ -0,0 +1,3 @@
+DIST time-0.2.0.tar.gz 25276 BLAKE2B e944fc0ad371608b24c543e503504e1bfd9015f8b998372e6e4a08d2b76c7d75b478ceac42d4d955c205e4ed30a018d3c008e947d9d3215fcd32d78f429aee92 SHA512 07b4896827014ab1f6394ee8a116a8074c2342c070b814bb190104a404828d684c9ca49d0c53fe5ef4518d5455de73d5f4c03051cbae47257fa631b17515d2f9
+EBUILD time-0.2.0.ebuild 984 BLAKE2B 5108c127a639f4d671047fe151b3a4bde18c7bf920728a7f5acc37cd95e1c69fd55394802f9640d83aabde4d2f462e1d3910233df683b3e537970db478858f63 SHA512 ee1285b4571407f706c9723ac726f6eb30fca13c6edf5b271c0ccbdb65fa40715b9da2a809760945ea4281027f18ff7398fc5267195971823777daffc7c155e4
+MISC metadata.xml 336 BLAKE2B 319e2c60fbca7c2a86ddd03dc6b837e5f596e12fa5b9dbf002a955c23e8eeeb26bb91a4526a6a67604b6eded037f99f8e95334899fea2d1b3d1715457eb7dc6c SHA512 8ab5bc044b940fea3297ab6cb12a4fd3204602558812dc059d59e8a7f72ebe137ae637127270c40e8fdec3a8c00c9778d109f499b4828ac4d03f38ed7b0fa292
diff --git a/dev-ruby/time/metadata.xml b/dev-ruby/time/metadata.xml
new file mode 100644
index 000000000000..3491d92c0b1d
--- /dev/null
+++ b/dev-ruby/time/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/time</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/time/time-0.2.0.ebuild b/dev-ruby/time/time-0.2.0.ebuild
new file mode 100644
index 000000000000..ae7b805d59f6
--- /dev/null
+++ b/dev-ruby/time/time-0.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="time.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extends the Time class with methods for parsing and conversion"
+HOMEPAGE="https://github.com/ruby/time"
+SRC_URI="https://github.com/ruby/time/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}