summaryrefslogtreecommitdiff
path: root/dev-ruby/tilt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-ruby/tilt
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/Manifest2
-rw-r--r--dev-ruby/tilt/tilt-2.0.9.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index 1e6682c63553..a8c30ec3dcfc 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1,5 +1,7 @@
DIST tilt-2.0.5.gem 52224 BLAKE2B c3bcd3cbf45ec3cd7669e5f3adb97f26508b5fc57fa234af8074422f7de62be8fca960d94a9b637b8adf8825b7b31cb5049b48bf75c08565b4ba42e2d37b3493 SHA512 b032439d00e09d3968b20f5ea5937c5918b1e10e0255cce402b6859b7d59ecdc265523a151c0fcca0034e0de26ca5fe422944790939896d7e0000641980764fa
DIST tilt-2.0.8.gem 54784 BLAKE2B 14b067227a1c81060b4627d39fadcae00300fa30c3b4741c2c07f0e69bbe62b1f1e8f3a165f43ff72c9788d3621a133375c3be72c9bf16f0c18686f550bc3c16 SHA512 1767f2e5ce45afe95d84d32de7c2b6fe24ff7cb6f7ee8485d84344820b2f6e969ae60a6fbaa7141f7fe135c6540d96fa5b27fd8010b95c0ded5d049a315001d5
+DIST tilt-2.0.9.gem 55296 BLAKE2B dd181295d2317ef591e9b89a0a4cf29680a05403c89c33680f563459ebbfc675bfaef14c864f8c8834103fc2ea069b33dc928f2b804d911eec21b09427f7c619 SHA512 522b2b40ca1eefc7df66cb421c66734699a2ffb1e7d1797181c2718f7ca018d3376c1a2b3617b5d3549115af69108db4c3c4632e2682329d5baf24bfdae92b42
EBUILD tilt-2.0.5.ebuild 1476 BLAKE2B 06c6e022c0a989f69995a62e893b0a4abd25f03ed9dc5d8daaaa8a6f02aa9856ede7e4e6e49624f88a0a6a11cf45ba27e99b3b4576fbe6a1a0dead5440d787db SHA512 89e0fcaf8fa663e5868f36b2b85192b0922e27ca0c9a3c82ced87c8b31d8d456dc994f67304a2c2908e07062ee225527cbef2c79d83a3e7fbe3b865e875353bb
EBUILD tilt-2.0.8.ebuild 1459 BLAKE2B 249675a6168a130385e08d0bf51760b99c53b63b39a61a3d800c3c0e11ddbcdca605f4f9d615b42da6611374d51f9cd2ba9f1c62d55e5087a09ff72570dbc0f0 SHA512 b7c940a530b0a7fd6471c868637da36434f51986997ad9e044ad1f610c72f6e8b1028a9ce984d3ef3d61473c45348eddf95928149792ae92c7f8b7b86b0eeebc
+EBUILD tilt-2.0.9.ebuild 1449 BLAKE2B 4c543ad860e0b43a1497e2ddc5f520100a693fc9a48d5a4c50eafe981d4bb68634056536fab80a9675c2a9354c49e7ee2d2c7b0ba11b464024f082140e0ce813 SHA512 695acfd1de9b445b98da7c5849fabf6455e979de664b88b80c364bd04ff12dccc69650718c7ec53d4e42f030639d1ec5d3b76279f98d90b743242e6279c0364d
MISC metadata.xml 339 BLAKE2B d8712c61994758c250248bbd14842a7b64d7808008e3d18fac9330bdc03dcbc6e721ffbb2cb813dea148036bcc40a60c4d8b1588b937a02712eb65c312ddb2db SHA512 f9ee61c88fa51f3fed6864d91c8f77bdcb492befce86f260a49faf141d6c11fc4563e57e1b35511571ec02a41cdb8f2111bb7ee76474d1bc65d81bbace15b730
diff --git a/dev-ruby/tilt/tilt-2.0.9.ebuild b/dev-ruby/tilt/tilt-2.0.9.ebuild
new file mode 100644
index 000000000000..efb26b7ad062
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/bluecloth
+ dev-ruby/coffee-script
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+ !!<dev-ruby/maruku-0.7.2 )"
+
+ruby_add_rdepend "!!<dev-ruby/tilt-1.4.1-r2:0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' \
+ -e '/test_smart_quotes_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+}