summaryrefslogtreecommitdiff
path: root/dev-ruby/tilt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-22 06:41:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-22 06:41:43 +0000
commitaaeed2da8906f11cba80355688015d74b01cc604 (patch)
tree5d714c0600fd3f185c0ddb96eef8dd41a5f3ec5e /dev-ruby/tilt
parent23b767af73549eeb4dd3069e09d0f2fcb88669a8 (diff)
gentoo auto-resync : 22:03:2023 - 06:41:43
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/Manifest2
-rw-r--r--dev-ruby/tilt/tilt-2.1.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index 97f49187400b..2a98c662991a 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1,3 +1,5 @@
DIST tilt-2.0.11.tar.gz 53041 BLAKE2B 2509cc3efe5e6302c8943c00108eeda6ee4b23a18952ad23049e11ea28b397b80a21d34c4d241119f45cedf2a978a2673d857a6cc32d7e26a2016caa510458f9 SHA512 e28e31ab92aa42eada34e0f6c05dab6a54945d07b649588356b1635ba8a36700f6e537e8702613883693501442d21690d8b3690b06f7b9f331192134511b78b7
+DIST tilt-2.1.0.tar.gz 54542 BLAKE2B b2d7729654efb51d9f61afe75476d6620edd7c104c045dc68c6a5e983cea8dec612d2e5013c51ee7736c87d770acdf8e6f186ff156d177f3281e0fb58d0e8422 SHA512 a450bdc51d782169cda2c43b550fad1425d4ee1a8f3c2da0bb1112051eb9ccfd95e903984ed6d3c76b0f322a243021587c6614f6452c385450ff1a985cfbcaa5
EBUILD tilt-2.0.11.ebuild 1370 BLAKE2B e8f9243019a58ecabf2cbd23bd9ab4337b081d3457b27e7eb1b8896fe74d50f8956182efb8d63a91641286fa9b716eae4a67ba871663d0d88bdd2aa27ba4cc25 SHA512 25c3d02a829f77a432df038f9386d267672d63ebfcd41b85ff1c674e6848e130ec632f0cecae19be85c0128c8afeb4d79a3c8bf5ba6765458b605a1b88aac0d3
+EBUILD tilt-2.1.0.ebuild 1380 BLAKE2B 73cccb33fd916e9c61b3e0edcab52f36c2ac364f5d448d7b1c1cdae3f9db6128c8d2885645012927c9ee2f957e60358b428d1e94445966a15acb8ff8bd0b6b34 SHA512 657e11fbef110d809f5b148d03a184b5e4fd07e145b809c74a2cbf096f7108f8a6b97c4f415a51b5d38166880c6e0a6337aeac1fa7b1c1b9809dea98063e0952
MISC metadata.xml 340 BLAKE2B 5414049365511f348e3da85bf3f207b791dc4269331e6a650f90398b6afe2502e2e62624ec9597a2d55dca4a7e4a99e209837c44bac7a901ec42139518f41647 SHA512 4be8002eca7cc4c0204311dd7dd187caeee3f40db9b00d108fb18e97009f8cec10d298a958bf83d24177297cebd78789cdd546a0c5e9c7288aa697dee1facf71
diff --git a/dev-ruby/tilt/tilt-2.1.0.ebuild b/dev-ruby/tilt/tilt-2.1.0.ebuild
new file mode 100644
index 000000000000..a1ad7679472a
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+RUBY_FAKEGEM_GEMSPEC="tilt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/jeremyevans/tilt"
+SRC_URI="https://github.com/jeremyevans/tilt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/erubi
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ rm -f test/tilt_sasstemplate_test.rb || die
+
+ # Skip tests for unpackaged asciidoctor converter
+ sed -i -e '/docbook 4.5/askip' test/tilt_asciidoctor_test.rb || die
+}