summaryrefslogtreecommitdiff
path: root/dev-ruby/tilt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/tilt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/Manifest5
-rw-r--r--dev-ruby/tilt/metadata.xml11
-rw-r--r--dev-ruby/tilt/tilt-2.0.5.ebuild43
-rw-r--r--dev-ruby/tilt/tilt-2.0.8.ebuild42
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
new file mode 100644
index 000000000000..1e6682c63553
--- /dev/null
+++ b/dev-ruby/tilt/Manifest
@@ -0,0 +1,5 @@
+DIST tilt-2.0.5.gem 52224 BLAKE2B c3bcd3cbf45ec3cd7669e5f3adb97f26508b5fc57fa234af8074422f7de62be8fca960d94a9b637b8adf8825b7b31cb5049b48bf75c08565b4ba42e2d37b3493 SHA512 b032439d00e09d3968b20f5ea5937c5918b1e10e0255cce402b6859b7d59ecdc265523a151c0fcca0034e0de26ca5fe422944790939896d7e0000641980764fa
+DIST tilt-2.0.8.gem 54784 BLAKE2B 14b067227a1c81060b4627d39fadcae00300fa30c3b4741c2c07f0e69bbe62b1f1e8f3a165f43ff72c9788d3621a133375c3be72c9bf16f0c18686f550bc3c16 SHA512 1767f2e5ce45afe95d84d32de7c2b6fe24ff7cb6f7ee8485d84344820b2f6e969ae60a6fbaa7141f7fe135c6540d96fa5b27fd8010b95c0ded5d049a315001d5
+EBUILD tilt-2.0.5.ebuild 1476 BLAKE2B 06c6e022c0a989f69995a62e893b0a4abd25f03ed9dc5d8daaaa8a6f02aa9856ede7e4e6e49624f88a0a6a11cf45ba27e99b3b4576fbe6a1a0dead5440d787db SHA512 89e0fcaf8fa663e5868f36b2b85192b0922e27ca0c9a3c82ced87c8b31d8d456dc994f67304a2c2908e07062ee225527cbef2c79d83a3e7fbe3b865e875353bb
+EBUILD tilt-2.0.8.ebuild 1459 BLAKE2B 249675a6168a130385e08d0bf51760b99c53b63b39a61a3d800c3c0e11ddbcdca605f4f9d615b42da6611374d51f9cd2ba9f1c62d55e5087a09ff72570dbc0f0 SHA512 b7c940a530b0a7fd6471c868637da36434f51986997ad9e044ad1f610c72f6e8b1028a9ce984d3ef3d61473c45348eddf95928149792ae92c7f8b7b86b0eeebc
+MISC metadata.xml 339 BLAKE2B d8712c61994758c250248bbd14842a7b64d7808008e3d18fac9330bdc03dcbc6e721ffbb2cb813dea148036bcc40a60c4d8b1588b937a02712eb65c312ddb2db SHA512 f9ee61c88fa51f3fed6864d91c8f77bdcb492befce86f260a49faf141d6c11fc4563e57e1b35511571ec02a41cdb8f2111bb7ee76474d1bc65d81bbace15b730
diff --git a/dev-ruby/tilt/metadata.xml b/dev-ruby/tilt/metadata.xml
new file mode 100644
index 000000000000..5ec123a4f728
--- /dev/null
+++ b/dev-ruby/tilt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rtomayko/tilt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/tilt/tilt-2.0.5.ebuild b/dev-ruby/tilt/tilt-2.0.5.ebuild
new file mode 100644
index 000000000000..5aa811eb95a4
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/bluecloth
+ dev-ruby/coffee-script
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+ !!<dev-ruby/maruku-0.7.2 )"
+
+ruby_add_rdepend ">=dev-ruby/builder-2.0.0:*
+ !!<dev-ruby/tilt-1.4.1-r2:0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' \
+ -e '/test_smart_quotes_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+}
diff --git a/dev-ruby/tilt/tilt-2.0.8.ebuild b/dev-ruby/tilt/tilt-2.0.8.ebuild
new file mode 100644
index 000000000000..283dbee57fb1
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/bluecloth
+ dev-ruby/coffee-script
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+ !!<dev-ruby/maruku-0.7.2 )"
+
+ruby_add_rdepend "!!<dev-ruby/tilt-1.4.1-r2:0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' \
+ -e '/test_smart_quotes_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+}