summaryrefslogtreecommitdiff
path: root/dev-ruby/tilt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-ruby/tilt
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/Manifest2
-rw-r--r--dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch37
-rw-r--r--dev-ruby/tilt/tilt-2.0.10-r1.ebuild46
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index 6cc766f4abf0..855c831fcb06 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1,3 +1,5 @@
+AUX tilt-2.0.10-ruby30.patch 1482 BLAKE2B 00647a8d443e9800bc9aa7e28d91b9f0ed59ad5e0802ae14b3b545d695181774bcd909ff459832b5e99316f39b9d548ee002fb23de6fcbf394ea73521519b85d SHA512 0f261a9d02e562326902433f10f1ea58a652c2f122d8d90ab2b74259b1d6bd551854802b5f19c07fc2998a45d82133fe3cc029012103e614faf22bd6fc766047
DIST tilt-2.0.10.tar.gz 51446 BLAKE2B de5c12dcf22994f182ae163a82c3060f1d0d8b4bc2a4495f28c9befc954b4949b9d2ae6aed42e3a9c35fb68825844881d9f15b2b68d949236e5396083ff199a3 SHA512 4a36c55347e307ea0c842aad3da72cebe98bcf8a0421040cfce7a43540d1746e736ce92b7ce7492a5cfc184372842c3ac7a006f3650b4c9420d5825ec005b4ef
+EBUILD tilt-2.0.10-r1.ebuild 1623 BLAKE2B 78f2743d88e98c88f01f584eb347e8eb0c6c4451225e79ec13d24e5dceae4b38a99dac95bceefbe316851ff54d407388b385d25872286caefc763e187789d907 SHA512 ace6e0bcef0513b38b73cba5aa1bc963ec2ba3da060507bc48fc8ba835611804fcd206fc9d02f8bf8102658879eaf9e473bca9339df518cf598cd35e955a525a
EBUILD tilt-2.0.10.ebuild 1603 BLAKE2B c046401f51f7a87aeff75991d0ddbbb6c402a1cc8dee8d867ac44922ddb72791e673d296353e5eeb5f52860230d10c2eceab6e056d29f85f7df7e78c3b355a31 SHA512 9c4f2a2c43b29c76e9ed970f44be4b6b8c5b4c96ab5b34e17dfcedad416d4487efa9a6ebab332bde09b1aea5870e4bf3ac1752505838ceb506d1a464b0f16531
MISC metadata.xml 340 BLAKE2B 5414049365511f348e3da85bf3f207b791dc4269331e6a650f90398b6afe2502e2e62624ec9597a2d55dca4a7e4a99e209837c44bac7a901ec42139518f41647 SHA512 4be8002eca7cc4c0204311dd7dd187caeee3f40db9b00d108fb18e97009f8cec10d298a958bf83d24177297cebd78789cdd546a0c5e9c7288aa697dee1facf71
diff --git a/dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch b/dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch
new file mode 100644
index 000000000000..27e4d821f64f
--- /dev/null
+++ b/dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch
@@ -0,0 +1,37 @@
+From 91838d57aa35ba5341368ead0d442e1dc1eb8730 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
+Date: Mon, 18 Jan 2021 12:49:31 +0100
+Subject: [PATCH] Fix Ruby 3.0 compatibility.
+
+This fixes issues such as:
+
+~~~
+ 1) Error:
+CSVTemplateTest#test_compiles_and_evaluates_the_template_on_render:
+TypeError: no implicit conversion of Hash into String
+ /usr/share/ruby/csv.rb:1273:in `initialize'
+ /usr/share/ruby/csv.rb:1273:in `new'
+ /usr/share/ruby/csv.rb:1273:in `generate'
+ (__TEMPLATE__):in `__tilt_920'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/lib/tilt/template.rb:170:in `call'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/lib/tilt/template.rb:170:in `evaluate'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/lib/tilt/template.rb:109:in `render'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/test/tilt_csv_test.rb:15:in `block in <class:CSVTemplateTest>'
+~~~
+---
+ lib/tilt/csv.rb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/tilt/csv.rb b/lib/tilt/csv.rb
+index fd0e602..7dfa220 100644
+--- a/lib/tilt/csv.rb
++++ b/lib/tilt/csv.rb
+@@ -50,7 +50,7 @@ def prepare
+
+ def precompiled_template(locals)
+ <<-RUBY
+- #{@outvar} = #{self.class.engine}.generate(#{options}) do |csv|
++ #{@outvar} = #{self.class.engine}.generate(**#{options}) do |csv|
+ #{data}
+ end
+ RUBY
diff --git a/dev-ruby/tilt/tilt-2.0.10-r1.ebuild b/dev-ruby/tilt/tilt-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..00b33d3ba691
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.10-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+RUBY_FAKEGEM_GEMSPEC="tilt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+SRC_URI="https://github.com/rtomayko/tilt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-ruby30.patch" )
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' \
+ -e '/test_smart_quotes_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+
+ # Skip tests for unpackaged asciidoctor converter
+ sed -i -e '/docbook 4.5/askip' test/tilt_asciidoctor_test.rb || die
+}