summaryrefslogtreecommitdiff
path: root/dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild')
-rw-r--r--dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild
new file mode 100644
index 000000000000..c85df21f5c21
--- /dev/null
+++ b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/tidy/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="W3C HTML Tidy library implemented as a Ruby extension"
+HOMEPAGE="https://github.com/carld/tidy"
+
+LICENSE="HTML-Tidy"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/11CVE-2015-5522.patch" )
+
+all_ruby_prepare() {
+ mkdir lib || die
+
+ # Remove reference to rspec 1
+ sed -i -e '/spec/d' spec/spec_helper.rb || die
+
+ # Avoid spec that needs network connectivity.
+ rm spec/tidy/remote_uri_spec.rb || die
+}