summaryrefslogtreecommitdiff
path: root/dev-ruby/thor/thor-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-ruby/thor/thor-1.2.1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-ruby/thor/thor-1.2.1.ebuild')
-rw-r--r--dev-ruby/thor/thor-1.2.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-ruby/thor/thor-1.2.1.ebuild b/dev-ruby/thor/thor-1.2.1.ebuild
index f9f2ad391d8f..6d32e78e0474 100644
--- a/dev-ruby/thor/thor-1.2.1.ebuild
+++ b/dev-ruby/thor/thor-1.2.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_DOCDIR="rdoc"
@@ -20,7 +20,7 @@ SRC_URI="https://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${
LICENSE="MIT"
SLOT="$(ver_cut 1)"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux"
+KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux"
IUSE="doc"
USE_RUBY="ruby26 ruby27" ruby_add_bdepend "
@@ -53,11 +53,14 @@ all_ruby_prepare() {
# Avoid currently broken readline specs (already fixed upstream)
#rm -f spec/line_editor/readline_spec.rb spec/line_editor_spec.rb || die
+
+ # Avoid spec failing on whitespace difference in error message
+ sed -i -e '/raises an error for unknown switches/askip "whitespace differences"' spec/parser/options_spec.rb || die
}
each_ruby_test() {
case ${RUBY} in
- *ruby30)
+ *ruby30|*ruby31)
einfo "Skipping tests due to circular dependencies"
;;
*)