summaryrefslogtreecommitdiff
path: root/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-13 12:10:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-13 12:10:18 +0100
commit9574298151cf44a3b410bdb7a7076e7bed72570d (patch)
treec1fb9a389e6d111603406f0036d0ef1da0491514 /dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
parentd728c1a6db84b373b0b4186e631b2aa407744751 (diff)
gentoo auto-resync : 13:08:2023 - 12:10:18
Diffstat (limited to 'dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild')
-rw-r--r--dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild b/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
index 05ab3874fa65..6c2e062a13c6 100644
--- a/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
+++ b/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
@@ -18,12 +18,12 @@ IUSE=""
ruby_add_bdepend "test? (
>=dev-ruby/minitest-5.0.8
- dev-ruby/mocha:1.0
+ dev-ruby/mocha:2
dev-ruby/rspec:3
)"
all_ruby_prepare() {
sed -i -e '/bundler/ s:^:#:' Rakefile || die
- sed -i -e '1igem "mocha", "<2"' test/test_helper.rb || die
+ sed -i -e '/mocha/ s/setup/minitest/' test/test_helper.rb || die
}