summaryrefslogtreecommitdiff
path: root/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild')
-rw-r--r--dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild b/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..29a9aa5571d5
--- /dev/null
+++ b/dev-ruby/test_construct/test_construct-2.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Creates temporary files and directories for testing"
+HOMEPAGE="https://github.com/bhb/test_construct"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/minitest-5.0.8
+ >=dev-ruby/mocha-0.14.0
+ dev-ruby/rspec:3
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}