summaryrefslogtreecommitdiff
path: root/dev-ruby/test-unit/test-unit-3.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
commite59b99df9503539c0231e655a17bccf83f8a270d (patch)
treedbd3fc51c710879436a4122898a3653c8c0d4ae8 /dev-ruby/test-unit/test-unit-3.6.1.ebuild
parent9fce2d9787c37a690336f5e345a49d83ee60bc8a (diff)
gentoo auto-resync : 25:06:2023 - 07:29:14
Diffstat (limited to 'dev-ruby/test-unit/test-unit-3.6.1.ebuild')
-rw-r--r--dev-ruby/test-unit/test-unit-3.6.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/test-unit/test-unit-3.6.1.ebuild b/dev-ruby/test-unit/test-unit-3.6.1.ebuild
new file mode 100644
index 000000000000..f0afb7f19eac
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-3.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md doc-install/text/*.md"
+
+RUBY_FAKEGEM_GEMSPEC="test-unit.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An xUnit family unit testing framework for Ruby"
+HOMEPAGE="https://rubygems.org/gems/test-unit"
+SRC_URI="https://github.com/test-unit/test-unit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Ruby-BSD BSD-2 ) PSF-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/power_assert"
+
+all_ruby_prepare() {
+ mv doc doc-install || die "moving doc directory out of the way failed"
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbin "${FILESDIR}"/testrb-3 testrb-2
+}