summaryrefslogtreecommitdiff
path: root/dev-ruby/test-unit/test-unit-3.3.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-ruby/test-unit/test-unit-3.3.9.ebuild
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-ruby/test-unit/test-unit-3.3.9.ebuild')
-rw-r--r--dev-ruby/test-unit/test-unit-3.3.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/test-unit/test-unit-3.3.9.ebuild b/dev-ruby/test-unit/test-unit-3.3.9.ebuild
new file mode 100644
index 000000000000..d77a19177a4d
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-3.3.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md doc-install/text/*.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An xUnit family unit testing framework for Ruby"
+HOMEPAGE="https://rubygems.org/gems/test-unit"
+
+LICENSE="|| ( Ruby GPL-2 ) PSF-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/power_assert"
+
+all_ruby_prepare() {
+ mv doc doc-install || die "moving doc directory out of the way failed"
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbin "${FILESDIR}"/testrb-3 testrb-2
+}