summaryrefslogtreecommitdiff
path: root/dev-ruby/stringio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ruby/stringio
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ruby/stringio')
-rw-r--r--dev-ruby/stringio/Manifest3
-rw-r--r--dev-ruby/stringio/metadata.xml11
-rw-r--r--dev-ruby/stringio/stringio-3.0.1.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/stringio/Manifest b/dev-ruby/stringio/Manifest
new file mode 100644
index 000000000000..ea88c1917477
--- /dev/null
+++ b/dev-ruby/stringio/Manifest
@@ -0,0 +1,3 @@
+DIST stringio-3.0.1.tar.gz 30570 BLAKE2B 385ebe0571ac63a694c8c07cbda74eb53983a163f91d800c880eea9fbd0ec7d53d5a92d03b8afc5a71c9e48bf1c017c2a055fb3bc09c2f555c1a7743cf19ad5a SHA512 7781ee20f7f3d546ee227d7366ac88731b65ea743c39280c4f3d2107d9001eef4a4d583760110817c31f4433f0a45812acd88a0b1b31b2863a8fdc3f54b19ea7
+EBUILD stringio-3.0.1.ebuild 931 BLAKE2B 7ad70cf5fc3ad1a86b30a599c715c0fe4abf5ead774ca5cbba6e4796fd1f5fdb4fc3f01582b5625a1f4eff0e232b56131b222c76caa83e5ed2ab9539f5c0bd23 SHA512 ad5909819f1b14e25b76c6c2e33249ba63fe95122cdf1f0c14120b31510d7c069c72526748cf2099e208ded7fc7e7b93f489b006b0174408605df8542871bf28
+MISC metadata.xml 340 BLAKE2B bd5f8222a43eb391d2d14a1b878fadefd9f8a322e87b5058d482df79d95d70f7ef19c54e7ae12dc29e7ffc84c72e630f0ca46ac095059263cdcf6047cb4fa4d9 SHA512 f1f32d2c4c13e19500a7ff23b684b180d3dba8a79e49b8cb57b80e265d09e06cb8b7a9e6b743158a140967b7ccbb991fdf51cb3a6e95be4e24378a5f85efcbb2
diff --git a/dev-ruby/stringio/metadata.xml b/dev-ruby/stringio/metadata.xml
new file mode 100644
index 000000000000..d1f032e54888
--- /dev/null
+++ b/dev-ruby/stringio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/stringio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/stringio/stringio-3.0.1.ebuild b/dev-ruby/stringio/stringio-3.0.1.ebuild
new file mode 100644
index 000000000000..120921dc24ce
--- /dev/null
+++ b/dev-ruby/stringio/stringio-3.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTENSIONS=(ext/stringio/extconf.rb)
+RUBY_FAKEGEM_GEMSPEC="stringio.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pseudo IO class from/to String."
+HOMEPAGE="https://github.com/ruby/stringio"
+SRC_URI="https://github.com/ruby/stringio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -e "/s.version =/ s/source_version/'${PV}'/" \
+ -e 's/__dir__/"."/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}