summaryrefslogtreecommitdiff
path: root/dev-ruby/stomp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/stomp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/stomp')
-rw-r--r--dev-ruby/stomp/Manifest3
-rw-r--r--dev-ruby/stomp/metadata.xml11
-rw-r--r--dev-ruby/stomp/stomp-1.4.4.ebuild21
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/stomp/Manifest b/dev-ruby/stomp/Manifest
new file mode 100644
index 000000000000..4f86183c3197
--- /dev/null
+++ b/dev-ruby/stomp/Manifest
@@ -0,0 +1,3 @@
+DIST stomp-1.4.4.gem 93696 BLAKE2B c1647ba119946ed41d58b1fe08baae5fa54317e3ba4b4b33eef50b7ff588daaf2ecf89a45b21b3eac7969609337fc8b09d73ea7f54f40af6c4b2613cab686df7 SHA512 77c5a53b56177869beb9ff236405479d1fe48ba6841f42eefbd104a5e1b8f82584283c909bb2f6ec5a34ae99c0dfa91079d0716d1bef65db24c5b1414c1ed673
+EBUILD stomp-1.4.4.ebuild 446 BLAKE2B f0988cec062813e456a334ee0e0397fe578f7d46be7c8cb00dedade018bf8b6dc498d346a0b3ed6d187253d9fb09f4553a049ff6148a1b94cc5aa7ee1d7347f1 SHA512 182fe4d9b410a4c27a4fc14269ef257c915c43b949cd65c1090c3f0bc129967fd3079ced1affa2b85fbe746e08c0228be5184a5a5238f8d5d5167e71dfc43f9d
+MISC metadata.xml 340 BLAKE2B a6651b0b90e84ece8ba5aca92bff77b66b97324fddd4b54aaf141ac0627bfb7ab5a9533c5610c3fbff944b354c938b12df8859cb5773f50b525072eef4a1d6eb SHA512 4abeb3f05f1cca14519cc2cb18d904bfb953ddf661b5ced2b5f790df590b863b41ab4b11ea9ca71bec60fa5bfcaddae84d216471c2b3cb2be6f01f2b965a592f
diff --git a/dev-ruby/stomp/metadata.xml b/dev-ruby/stomp/metadata.xml
new file mode 100644
index 000000000000..cefb771aa9fc
--- /dev/null
+++ b/dev-ruby/stomp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">stompgem/stomp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/stomp/stomp-1.4.4.ebuild b/dev-ruby/stomp/stomp-1.4.4.ebuild
new file mode 100644
index 000000000000..cf57278dc9fe
--- /dev/null
+++ b/dev-ruby/stomp/stomp-1.4.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for the stomp messaging protocol"
+HOMEPAGE="https://github.com/stompgem/stomp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""