summaryrefslogtreecommitdiff
path: root/dev-ruby/stomp/stomp-1.4.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-ruby/stomp/stomp-1.4.9.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-ruby/stomp/stomp-1.4.9.ebuild')
-rw-r--r--dev-ruby/stomp/stomp-1.4.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/stomp/stomp-1.4.9.ebuild b/dev-ruby/stomp/stomp-1.4.9.ebuild
new file mode 100644
index 000000000000..089aa7105eaa
--- /dev/null
+++ b/dev-ruby/stomp/stomp-1.4.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for the stomp messaging protocol"
+HOMEPAGE="https://github.com/stompgem/stomp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Skip specs that hang the test run indefinitely, most likely
+ # because of rspec-mocks deprecation output
+ rm -f spec/connection_spec.rb || die
+}