summaryrefslogtreecommitdiff
path: root/dev-ruby/state_machine/state_machine-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/state_machine/state_machine-1.2.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/state_machine/state_machine-1.2.0.ebuild')
-rw-r--r--dev-ruby/state_machine/state_machine-1.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/state_machine/state_machine-1.2.0.ebuild b/dev-ruby/state_machine/state_machine-1.2.0.ebuild
new file mode 100644
index 000000000000..2757123094a7
--- /dev/null
+++ b/dev-ruby/state_machine/state_machine-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds support for creating state machines for attributes on any Ruby class"
+HOMEPAGE="http://www.pluginaweek.org"
+IUSE="test"
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/{unit,functional}/*_test.rb
+}