summaryrefslogtreecommitdiff
path: root/dev-ruby/stamp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/stamp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/stamp')
-rw-r--r--dev-ruby/stamp/Manifest3
-rw-r--r--dev-ruby/stamp/metadata.xml11
-rw-r--r--dev-ruby/stamp/stamp-0.6.0.ebuild34
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/stamp/Manifest b/dev-ruby/stamp/Manifest
new file mode 100644
index 000000000000..490b115bf856
--- /dev/null
+++ b/dev-ruby/stamp/Manifest
@@ -0,0 +1,3 @@
+DIST stamp-0.6.0.tar.gz 9099 BLAKE2B 6e5d4b95fcd6f31f47b02a4053670fad53e982bd965120f02ef3751e9b499d21a0867ef11afd628eeb2b1bcc523e3423aa319103868554b4c74341253614b1b3 SHA512 2f467444bad3c8932aeaeda061796ee3469b16d908027325efa28f7da005c8a4c8c95f0d3b84b6b1040bf5e5fe4114fc4779e3c9efc6c00817a050c13be62472
+EBUILD stamp-0.6.0.ebuild 786 BLAKE2B e2d11998e7219274644208bcfe83178100f226e8d7c913def8373c02b1928df14e254ca0a3942cdae78322578dae7227eb80add3c5dd49f3ed2327571d068ca7 SHA512 c55855b18bbf8ca620ecd28ae8ee2130eb8f637d2e7e439b1f5d66feadc69043acdbd8175e6ade69f8b876e7eaeb960f9505c2f2e73e6f3e46760565d0383294
+MISC metadata.xml 339 BLAKE2B 39578762fb4e2cabf1c1d57b6644848565610013bb0cb5a0885eaf2923dcbc9ac2246e5ae22d688fc4c1eb607a3caf2288ed45400b635debd87a2e20c99bee6b SHA512 b81167c6ad8195382cfb07051680ea331441869f33b0e9eee25c86b18ca6f107b7e464581d0f63422ca2c81ead34d8bb51cebdb1e9cb7afffdb99fa6e2d33329
diff --git a/dev-ruby/stamp/metadata.xml b/dev-ruby/stamp/metadata.xml
new file mode 100644
index 000000000000..e5181ba91213
--- /dev/null
+++ b/dev-ruby/stamp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jeremyw/stamp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/stamp/stamp-0.6.0.ebuild b/dev-ruby/stamp/stamp-0.6.0.ebuild
new file mode 100644
index 000000000000..42f25e85d6a3
--- /dev/null
+++ b/dev-ruby/stamp/stamp-0.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="cucumber"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Date and time formatting for humans"
+HOMEPAGE="https://github.com/jeremyw/stamp"
+SRC_URI="https://github.com/jeremyw/stamp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile || die "sed failed"
+ sed -i -e '/bundler/,+7d' features/support/env.rb || die "sed failed"
+}