summaryrefslogtreecommitdiff
path: root/dev-ruby/stamp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/stamp
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/stamp')
-rw-r--r--dev-ruby/stamp/Manifest2
-rw-r--r--dev-ruby/stamp/stamp-0.6.0-r1.ebuild (renamed from dev-ruby/stamp/stamp-0.6.0.ebuild)13
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-ruby/stamp/Manifest b/dev-ruby/stamp/Manifest
index 09cbd1985085..b27474b96191 100644
--- a/dev-ruby/stamp/Manifest
+++ b/dev-ruby/stamp/Manifest
@@ -1,3 +1,3 @@
DIST stamp-0.6.0.tar.gz 9099 BLAKE2B 6e5d4b95fcd6f31f47b02a4053670fad53e982bd965120f02ef3751e9b499d21a0867ef11afd628eeb2b1bcc523e3423aa319103868554b4c74341253614b1b3 SHA512 2f467444bad3c8932aeaeda061796ee3469b16d908027325efa28f7da005c8a4c8c95f0d3b84b6b1040bf5e5fe4114fc4779e3c9efc6c00817a050c13be62472
-EBUILD stamp-0.6.0.ebuild 790 BLAKE2B 67559b8f2d98fc293b25ef8175d17453136109117a078958a3dbac1edbdc113f70291707787ea1df78e5fafab2ccdfc0d75e6322f1fe4053f47421a3b54421f3 SHA512 f2d79fd8a117c324eeb5aaad76f533f89aa7b2657ea360dbb1979dfbb3ba467fbd3b14569cef88d448f87f0a03dddda52523c5a1671d3a39ce70c2ef8b34cdbe
+EBUILD stamp-0.6.0-r1.ebuild 985 BLAKE2B 271be45b73d026c3a34de7b878605d6f0242f07594ee9887920847a13467ef64658943501a14f4c6228b90b1040e69223bf9dc65ba9ea0315d6c45a8bfbc03c9 SHA512 a1518d66702548733a67b5a24f8d07062f7929c26d650834cb34d5af2e3c5cca3c6a452eb8a51254313e5dba9092282c6a3a9eee162e79c404f167764e121a8f
MISC metadata.xml 340 BLAKE2B 9789125ddca307508807e81f3d319db304ac97699a7b4003fd40a8f1a06e9fba4fa113cfa465cb6107cc80641d5f3fc7cec7b3e0128fd242f92a1e86966db120 SHA512 2727b134a4b8c9ffd678a879dc2f11d9631c3abece335bc63c0c98ae6472340da798f220364646daf239d1d6972b94ad6856db17ff3da0e2e93fd2669803a616
diff --git a/dev-ruby/stamp/stamp-0.6.0.ebuild b/dev-ruby/stamp/stamp-0.6.0-r1.ebuild
index a9a97ae84584..57d0cf49d992 100644
--- a/dev-ruby/stamp/stamp-0.6.0.ebuild
+++ b/dev-ruby/stamp/stamp-0.6.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+USE_RUBY="ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_TEST="cucumber"
RUBY_FAKEGEM_TASK_DOC=""
@@ -12,6 +12,8 @@ RUBY_FAKEGEM_RECIPE_DOC="yard"
RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_GEMSPEC="stamp.gemspec"
+
inherit ruby-fakegem
DESCRIPTION="Date and time formatting for humans"
@@ -31,4 +33,9 @@ ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
all_ruby_prepare() {
sed -i -e '/bundler/d' Rakefile || die "sed failed"
sed -i -e '/bundler/,+7d' features/support/env.rb || die "sed failed"
+
+ # Remove obsolete and unneeded cucumber settings
+ rm -f cucumber.yml || die
+
+ sed -i -e 's/git ls-files --/find/; s/git ls-files/find */' ${RUBY_FAKEGEM_GEMSPEC} || die
}