summaryrefslogtreecommitdiff
path: root/dev-ruby/sshkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-ruby/sshkit
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-ruby/sshkit')
-rw-r--r--dev-ruby/sshkit/Manifest2
-rw-r--r--dev-ruby/sshkit/sshkit-1.21.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/sshkit/Manifest b/dev-ruby/sshkit/Manifest
index 959e789d5fe7..a4ea54822df3 100644
--- a/dev-ruby/sshkit/Manifest
+++ b/dev-ruby/sshkit/Manifest
@@ -1,3 +1,5 @@
DIST sshkit-1.20.0.gem 155648 BLAKE2B fdb95aed6d407c598abde71591cbe2d7b1f98d91985695509a6545bcabc5c0f3337cfe8f73e82f4b212e3c04b6da09e7521637934baeea7a9b5e268ff72fcad1 SHA512 682234f99d6ae9533c99f0319ad0f3732f2ff166a8f1a07d5ce8ff59fd9606af9440798a39f657dd3899e9278639aa93d5fb29af8f64b2ebea7f3b8e75fb25fa
+DIST sshkit-1.21.0.gem 144384 BLAKE2B f4f77d9cf00db4bc0ab6ac092dc859af31fd50976fc9425c0e5ba1b5c1607bd9b50fff44f65f0207b9d9d604c5ace153ba05ec062fb064c44673572769416a22 SHA512 981fdaa19d633e92d4e3ef5fc9255a89d992813c400af4a468e6cf12ca52cbe612b771a87afe6392c4098d07b42162d5981025b8b214aafa197a68222b5e234e
EBUILD sshkit-1.20.0.ebuild 1160 BLAKE2B 0d991bef3cb64cdf8d9c3325212092ff7534d8469b80c886ad3988179b2813bbbacd5a446746ed9963587963a2f2a74aa18231e5636da857a4ed40b3b834a06f SHA512 d011cacdd85ab31275bc552fb874371c73aaf9771b11bbf2cbae47099563ebe5bffd1999898cf5aa900db413967bbddd39c961deb92264711ddbb0f94ef2e75f
+EBUILD sshkit-1.21.0.ebuild 1161 BLAKE2B cbc954091a2839e4cb35f013139b68fd886c7b8659af777be13c545d09d8467363b93d011ae70728ebeafc0f28a86b662cfe3520b5cf6bbc381e2a4ded038f6e SHA512 28c6ff1acab4a332fda56ca91c67be14dbd410039b4582ea5804d3ada0b16f93de2f1f3092cf241a2dfd568f11e4f08cfe5a4137175ea137ecee162bad3566df
MISC metadata.xml 343 BLAKE2B 0f8326d45916642aa200df9ede8640367ffbf73022b847f54f8869884a592489bc26a0da45406cd5409973e43290dafa3cb785460e7da61c20de3a796e025a03 SHA512 852971e242c5500cf6ce4fb0c2bc58560b96fdb8cc0f366fa41cac8e066f408330962cb86a35171c08bdea3493be81fbb10bb501ce207f7016a2a1b7c42d263b
diff --git a/dev-ruby/sshkit/sshkit-1.21.0.ebuild b/dev-ruby/sshkit/sshkit-1.21.0.ebuild
new file mode 100644
index 000000000000..8b726b006ab6
--- /dev/null
+++ b/dev-ruby/sshkit/sshkit-1.21.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+# There are functional tests that require vagrant boxes to be set up.
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
+HOMEPAGE="https://github.com/capistrano/sshkit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.8.0:*
+ >=dev-ruby/net-scp-1.1.2
+"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
+ sed -i -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
+ -e '1irequire "set"; require "pathname"' test/helper.rb || die
+
+ # Fix assumption about parent directory name
+ sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
+}
+
+each_ruby_test() {
+ # Run tests directly to avoid dependencies in the Rakefile
+ ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
+}