summaryrefslogtreecommitdiff
path: root/dev-ruby/sourcemap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/sourcemap
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/sourcemap')
-rw-r--r--dev-ruby/sourcemap/Manifest3
-rw-r--r--dev-ruby/sourcemap/metadata.xml11
-rw-r--r--dev-ruby/sourcemap/sourcemap-0.1.1.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/sourcemap/Manifest b/dev-ruby/sourcemap/Manifest
new file mode 100644
index 000000000000..832bf6368eb1
--- /dev/null
+++ b/dev-ruby/sourcemap/Manifest
@@ -0,0 +1,3 @@
+DIST sourcemap-0.1.1.gem 15872 BLAKE2B fac8ae7604a5d5a56b6aff82742b8c773bebfdeb41be6b6aeb3f2b5aff9c6cb2bf584b29ee7a6cfcb4b3064e6b1666e6c0341383fa4d39037759fcbf51ae57ee SHA512 d197a3aab0fe8c9e620c50d3bd994ed957b37dba071f6abc3b8a149a8a0490ee1b89512036b833ec44e6bdcdca6dacbdda9872036ba51736ac1d1e1f160ded59
+EBUILD sourcemap-0.1.1.ebuild 472 BLAKE2B d1a21811ee69f7e85f407d3f4c563ac63eb730f408b2ff071d013d9fb543860af1cfb9ffb9559f04cbcb202f0deaff2b7674facdfaf579b51921cda1c72e75ef SHA512 344e6da03537723ac69f4306030932f42195c5aff3e2a9e539a37aa3ea1b2419ef2bcd93fd9ea2f58234f8d0c6f93dc0a4a97e6f68a8e17a95da8cd28670b6be
+MISC metadata.xml 343 BLAKE2B a8f9658e9fea493c4d839537333079971a0b6afc29a46258763c8febf0862925f02bbdeb1696528c2e752a625d9e536282aad3cea7edbb624e3b1ebc2a545e49 SHA512 5347372e3013b627aeb9194714f4a1525a232b1d85eb252d2537606639ab95ce351396a094ffbcacb0caf5c153b77f4381abdcf8670b914b9fb43c26a05c3e4c
diff --git a/dev-ruby/sourcemap/metadata.xml b/dev-ruby/sourcemap/metadata.xml
new file mode 100644
index 000000000000..d55a65da9bec
--- /dev/null
+++ b/dev-ruby/sourcemap/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">maccman/sourcemap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/sourcemap/sourcemap-0.1.1.ebuild b/dev-ruby/sourcemap/sourcemap-0.1.1.ebuild
new file mode 100644
index 000000000000..16f1345a31a8
--- /dev/null
+++ b/dev-ruby/sourcemap/sourcemap-0.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby source maps"
+HOMEPAGE="https://github.com/maccman/sourcemap"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}