summaryrefslogtreecommitdiff
path: root/dev-ruby/sorted_set/sorted_set-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /dev-ruby/sorted_set/sorted_set-1.0.3.ebuild
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'dev-ruby/sorted_set/sorted_set-1.0.3.ebuild')
-rw-r--r--dev-ruby/sorted_set/sorted_set-1.0.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/sorted_set/sorted_set-1.0.3.ebuild b/dev-ruby/sorted_set/sorted_set-1.0.3.ebuild
new file mode 100644
index 000000000000..886a0324f926
--- /dev/null
+++ b/dev-ruby/sorted_set/sorted_set-1.0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="sorted_set.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements a variant of Set whose elements are sorted in ascending order"
+HOMEPAGE="https://github.com/knu/sorted_set"
+SRC_URI="https://github.com/knu/sorted_set/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/rbtree
+ dev-ruby/set:0
+"