summaryrefslogtreecommitdiff
path: root/dev-ruby/slop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-ruby/slop
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-ruby/slop')
-rw-r--r--dev-ruby/slop/Manifest2
-rw-r--r--dev-ruby/slop/slop-4.8.2.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/slop/Manifest b/dev-ruby/slop/Manifest
index 6eaa87478b6d..2b38776636ed 100644
--- a/dev-ruby/slop/Manifest
+++ b/dev-ruby/slop/Manifest
@@ -1,3 +1,5 @@
DIST slop-4.8.1.tgz 16805 BLAKE2B 875b9a1895d99147f6d597b976831fcb406170d6172ad4c888f53cb18e35439f9fc6bcf785864a3209de5169166b2760d196e1f2f102308db3aec07950fe5e88 SHA512 4edace1693081ab7f9d1efaeb9c894f34c0012ae827ee13bd1c8014c222e88db20b082be3d6b0a97e664135b2ba09bec9e7ecb0d20c22b32a859ac574fd2b71e
+DIST slop-4.8.2.tgz 16102 BLAKE2B c43af7350346961db1b19db2fbded24dc8a5483cf487f6dd6f6c486f9539984048f43eef7c3152da42b4c833eb9ec75d7ebfd89c7e759e5e5279bd5f69992f6a SHA512 1747981d5723b935f4d2a89787cf090645e43793b7430d43687dde6dc7e0bc8b52c30497f656e360e0cb95d62f3abb19d9dc4aebb617da57de1211104217bdc4
EBUILD slop-4.8.1.ebuild 672 BLAKE2B a05f5fb795e3f6808c10a3c50533c484cfbf465b75b75ff546d72a7a5b911296d67a784ea20305f8c609880373ac396713075cd7a0d32d4cbddb7cc21d1062cd SHA512 cd5f02db3c2d40b7b5e08e2e60858283c49b8779d190775627eb6dd502ed16ad72d0fe597640886b276b6699a4a6ef54acc18d449837520f008391884ca0a8db
+EBUILD slop-4.8.2.ebuild 665 BLAKE2B 3cb6288596c2cf8974327aa93fede7b97aab61978044fb5942a6b1c4fd0616e2dfa903059429d33a8ad27a8a881f7463d34096fd547c45b211525d75b075885d SHA512 d18192b49e02c227c13012ffdb9bacbc5cd044b1955d9d38b90b119bea17d9559e7259f85d4daff21d8ec289c07fce82f988d0ae4527704f520d080d6a50f561
MISC metadata.xml 337 BLAKE2B 257bf07d00a3f336c737c4135fae690b12a7b383de865d09fca95667efdfc4d66adcb55343b064c1fefa190f1f7c21c7b3f18ecde8d73e9d7632209ee8adc720 SHA512 2036c518a80c08e41ddec04f397959241a28fdbec0071c98120bbe2fade6e69ef67b1aa46191099520dced091d5aa0d16ae1484d831061c0681315cb0fa3b35a
diff --git a/dev-ruby/slop/slop-4.8.2.ebuild b/dev-ruby/slop/slop-4.8.2.ebuild
new file mode 100644
index 000000000000..6618224d5852
--- /dev/null
+++ b/dev-ruby/slop/slop-4.8.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="slop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' slop.gemspec || die
+}